1

I have a QGIS project that I have spend a lot of time styling over a 80 layers and it seems to have somehow become unstable. I believe that I renamed a folder containing some layer source files which caused QGIS to crash when I reopened the project. After renaming the folder back, the project opens but now will not let me add new layers (says QGIS can't run the Projection Coordinate Selection tool, and nearly every time I use the "Browse" function (in any context), the app crashes. Sometimes I get the Handle Bad layers dialog for two layers, and I can't Browse to find them because it crashes, but then when I reopen it, they are good anyway. Also, I cannot save any Symbol styling as templates without crashing.

Anyway, none of this occurs in a blank project, so I would like to import layers one at a time from my old project into a new project keeping the styling, etc. I see the Embed Layers feature, but it does not allow me to make modifications to the layers afterward. I read about a plugin called ImportLayersfromProject, but I cannot seem to find it on the web anywhere.

I am using QGIS 1.8 on Mac 10.7.5. I would prefer to not upgrade to the latest QGIS until after I complete this big project I am working on. Is there any way of getting the layers imported and being able to edit them too?

  • Thanks for the comment. Maybe this is a stupid question, but how would I open both the old project and the new project at the same time? – T Andrew Jan 10 '15 at 20:47
  • Sorry I skipped some text from your question.So when you import one project layer into a new (blank) project and copy paste the layer styles it doesn't work?Did you try to open your project on another machine (+ copying the folders)?Yes you can open two QGIS projects at one time. – Stefan Jan 10 '15 at 20:49
  • Ah yes! That does work, I misunderstood your comment before. Thanks! Still, though, I wish I could find that plugin for 1.8 (found it, but it requires 2.0) – T Andrew Jan 10 '15 at 20:52
  • Stefan' work around is successful, so my issue is resolved. – T Andrew Jan 10 '15 at 21:00
  • @Stefan please post your comment as an answer so this thread can be marked as solved – underdark Jan 10 '15 at 21:03
2

This is maybe not the smartest solution:

  1. Open your (the big) project and a new (blank) project. You can have many QGIS projects open at one time.

  2. Import all your project layer into the new (blank) project and copy-paste the layer styles.

2

It turns out that using Embed Layers and Group with copy/paste of the styles to newly added layers was not working with layers with graduated styling. When I copied and pasted the styles, the affected attribute column would change to the wrong one, and when I changed it back, the styles would reset to the default graduated style. I did find another solution. I was able to download ImportProject plugin and I can import the layers from my old project and edit them.

1

The ImportProject plugin was broken for me on MacOS 10.11 with QGIS 2.18.9, and I was looking for a work-around. The following simple procedure worked pretty well:

  1. Embed the required layer(s) from the source QGIS project. The embedded layers are not editable and linked to the source project.
  2. Duplicate the required layer(s) and rename the resulting layers if required. The resulting layers will be editable and not linked to the source QGIS project.
  3. Remove the embedded layers(s).
  • I had a problem with hundreds of embedded layers in QGIS Madeira - it was impossible to close the project, as the loading task was indefinitely active. This seems to help – Piotr Sadowski Dec 20 '18 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.