Errors when syncing edits using ArcGIS collector.

I have two users (the only ones using the map) experiencing sync errors when taking a collector map offline and trying to sync up their edits...

Both users downloaded a fresh version of this map for a weekend collection, they then returned with their devices to wifi spots and tried to sync their data, which resulted in the following error.

This function was previously working with this map but has been problematic for the last month. The map is also embeded here if you would like to take a look http://www.clubhubssl.com/rss/CMS1246/

Any suggestions on ways to fix this?

Should I make another map for collections and delete this problem one?

Can I use the same datasets for the new map?

enter image description here


This error was caused by two users sharing one account. I was unaware of it, but they did manage to both signin, download the map and then when it was time to sync the data this error occured. I reset passwords and republished the map.

| improve this answer | |
  • @AnythinhMapping, what do you mean by "republishing" a map? I'm experiencing the same issue here, but I have only one user using the map. Did you manage to sync back the data from the devices after the fix, or did you lose it all? – Horizen May 31 '17 at 20:05
  • 1
    @Horizen I did manage to save 50% of the data but I'm not sure it will help you. Firstly I changed to password on the account in question and made my one user log back in. I got this error because the users went offline and then tried to reconnect. I archived all of the data in the map then deleted everything. Once there was nothing in the map there was no possibility of conflict and the sync seemed to work. – AnythingMapping Jun 5 '17 at 23:33

You can manually extract the unsynced data from each tablet. You will need to physically cable them to your laptop. Or get your fieldworkers to do this. I have used the Android instructions here with no issues: https://support.esri.com/en/technical-article/000012460

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.