1

I'm trying to install the GEarthView plugin but without success. The following message pops up after installation:

"No module named zope.interface"

What is the problem?

QGIS 2.6.0 Windows7 (64Bit)

1
  • Following error now occur: !QGIS 2.8 Solutions?
    – user48066
    Feb 25, 2015 at 12:31

2 Answers 2

2

There is a big advice Install, before, the following python libraries: twisted\ Twisted-13.0.0-py2.7-win32 ( https://pypi.python.org/pypi/Twisted/13.0.0 ) zope\ zope.interface-3.6.0-py2.7-win32 ( https://pypi.python.org/pypi/zope.interface/3.6.0 )in the plugin window.

Unfortunately, there is no package of zope.interface-3.6.0 for Python 2.7, which QGIS uses. You may try newer versions of zope.interface that support Python 2.7 as well:

https://pypi.python.org/pypi/zope.interface/3.6.7

up to

https://pypi.python.org/pypi/zope.interface/4.1.2

See also https://github.com/geodrinx/gearthview/issues/1

1
  • No, sorry. The zope installation needs python 2.6. I'm using 2.7. I tried to install the 2.6.6. But after the installation the zope installation can't find Python 2.6
    – Pimpel
    Jan 12, 2015 at 9:56
1

On Windows, you need to copy

zope twisted

inside the QGIS path. For example:

QGIS Brighton\apps\Python27\Lib\site-packages\twisted\ QGIS Brighton\apps\Python27\Lib\site-packages\zope\

1
  • When you say copy, what do you mean? There are 4 files to download on the twisted repository, for example. One is a Windows installation file which does nothing. Do we just download one of the others and copy it into those folders?
    – Kelderic
    Feb 19, 2015 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.