4

i using Arcmap and i have a raster file, i need export this using a Geotiff file for use in Geoserver like a layer.

My problem is, when i export the file always exist a color gray or white in the background.

In frame properties i select white background with 'no color', when export geotiff in format tab, i select in background color 'no color'.

Exist another way for found some solution?

2

Tiff doesn't support 'transparent' like GIF. You need to set NoData value, open the raster properties dialog in ArcCatalog (right click on image):

enter image description here

In the highlighted line click on the Edit.. button:

enter image description here

And enter the value for the background. Then press OK and OK to dismiss both dialogs. Now GeoServer (and ArcMap and QGIS and GRASS...) should know that the background value is not to be shown.

  • My raster has 4 bands, the fourth being the alpha channel, so I had to specify 255, 255, 255, 0 to get it to work. – Jordan Biserkov Jun 17 '16 at 8:47
  • Alpha is a bit different @JBiserkov, different packages implement (or not) the alpha transparency channel differently. While it's true that a 4 band image needs 4 band NoData value theoretically NoData should be redundant where the alpha contains a 0/255 binary mask... this is dependent on the software implementation of course; what package did you implement 255,255,255,0 NoData in? – Michael Stimson Jun 20 '16 at 22:00
  • @michael-miles-stimson ArcMap – Jordan Biserkov Jun 29 '16 at 9:49
  • That would work in ArcMap @JBiserkov, however there is another way to implement Alpha in ArcMap, in the raster layer properties::symbology tab like resources.arcgis.com/en/help/main/10.2/index.html#//… - this is particularly good for ECW and JP2 where NoData value cannot be enforced due to compression, unfortunately the alpha band is not selected by default so every time you add the raster to your TOC you need to enforce this setting (or 'save as layer file' when you've set the properties and add the layer file instead in the future). – Michael Stimson Jul 3 '16 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.