1

An error has occured while executing Python code:

Traceback (most recent call last):
  File "/usr/share/qgis/python/pyplugin_installer/installer_data.py", line 460, in xmlDownloaded
    if isCompatible(QGis.QGIS_VERSION, qgisMinimumVersion, qgisMaximumVersion):
  File "/usr/share/qgis/python/pyplugin_installer/version_compare.py", line 188, in isCompatible
    if len(maxVer)TypeError: object of type 'NoneType' has no len()

Python version:
2.7.6 (default, Mar 22 2014, 23:03:41) 
[GCC 4.8.2]

When trying to open the plugin manages on Qgis 2.6.1 I get the following error:

QGIS version:
2.6.1-Brighton Brighton, exported

Python path: ['/usr/share/qgis/python/plugins/processing', '/usr/share/qgis/python', u'/home/joseph/.qgis2/python', u'/home/joseph/.qgis2/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/pymodules/python2.7', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client', '/usr/share/qgis/python/plugins/fTools/tools']
  • I'm busy fixing this and pushing through a fix. Can you confirm how you realised it is InaSAFE causing the problem? I don't see InaSAFE referenced in any of the listings above. – user3849375 Jan 14 '15 at 7:03
  • A new build has been pushed up so this is fixed now – Nathan W Jan 14 '15 at 9:42
2

The problem is caused by a plugin, inasafe, in the QGIS Python Plugins Repository that has a maximum version of 2.999.9999 which causes the error enountered.

The entry for the latest version of InaSAFE - 2.2.2 - has an invalid QGIS MAximum Version. Perhaps setting it to 2.99 as previously would be the thing to do.

2

if you go to https://plugins.qgis.org/plugins/plugins.xml?qgis=2.6 you will see the version error.

I am facing this problem as well. However, I can't find many users report about this problem, so I think it should be the computer setting problem ?

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.