0

Have a model that converts an excel table to a geodatabase table and converts a shapefile to a layer. Then joins the geodatabase table and layer together. After the join I want to create a new layer with specific attributes using an expression. However when I click on "get values" to build my expression, no data for any of the fields comes up.

Wondering if I'm missing a step after the join? Or if ModelBuilder doesn't let you select attributes since the join hasn't actually happened yet?

enter image description here

  • does your join rely on the field calculation ? Maybe you have to type your expression without the get value because the values possibly change in your workflow – radouxju Jan 14 '15 at 15:16
  • Big time thanks radouxju. My join did rely on a field calculation and concatenated the field names. I was originally using the concatenated field names in my expression. When I Used the original field name with the expression it worked. Was a little thrown off becuase when I tried to verify the expression it said there was an "error", must have something to do with the join. – ZachS Jan 14 '15 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.