7

I'm having issues with installing GDAL on a fresh install of Centos7 using the ELGIS repo. Here's my commands and output:

sudo rpm -Uvh http://elgis.argeo.org/repos/6/elgis-release-6-6_0.noarch.rpm
sudo yum install -y gdal

Here are the console errors:

--> Finished Dependency Resolution
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libCharLS.so.1()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libhdf5.so.6()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libnetcdf.so.6()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libdap.so.11()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libdapclient.so.3()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libxerces-c-3.0.so()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libdapclient.so.3()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libhdf5.so.6()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libCharLS.so.1()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libmysqlclient.so.16()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libdapserver.so.7()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libfreexl.so.1()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libxerces-c-3.0.so()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libmysqlclient.so.16()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libcfitsio.so.0()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libpoppler.so.5()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libgta.so.0()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libcfitsio.so.0()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libnetcdf.so.6()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libdapserver.so.7()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libarmadillo.so.3()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libgta.so.0()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libfreexl.so.1()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libdap.so.11()(64bit)
Error: Package: gdal-1.9.2-4.el6.x86_64 (elgis)
       Requires: libarmadillo.so.3()(64bit)
Error: Package: gpsbabel-1.4.4-1.el6.x86_64 (elgis)
       Requires: libshp.so.1()(64bit)
Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis)
       Requires: libpoppler.so.5()(64bit)

Is there another repo I need to install to make this work?

4

ELGIS requires EPEL (see https://fedoraproject.org/wiki/EPEL/FAQ#howtouse for EPEL).

However I'm not sure that you really want to use ELGIS 6 on CentOS 7. Its intended for RHEL 6 / CentOS 6 / Scientific Linux 6.

Instead, you probably just want to use EPEL for CentOS 7 for something like GDAL. EPEL 7 has GDAL 1.11.0, which isn't quite the latest, but is certainly more current than the 1.9.2 that are you trying to install.

  • thanks for the response. this worked. GDAL is in the EPEL repo for CentOS so the ELGIS repo is not necessary. – Alexander Rolek Jan 16 '15 at 16:40
  • 2
    It was enough to yum install epel-release and then yum install gdal in my case. – Ezze Jan 24 '18 at 21:12
0

For those who are new to EPEL, first you have to install EPEL. You can enable it for good, depens on you :)

yum -y install epel-release
yum install --enablerepo=epel gdal

If it is not regular yum repo, I search the internet "centos 7 'libraryname'" and if its on EPEL, the result usually poppes out. Or I visit EPEL repo and search here, usually their lib names are shortcuted. Also you can search the repo in the command line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.