3

I'm creating maps with a specified scale for the map window in QGIS Composer. Project CRS is WGS84, layers are WGS84, onthefly-transformation enabled. The area is approx. 1° x 1° (100 x 100 km). But when I measure and calculate the scale manually on the printed map and with the measure tool (metres) in QGIS, the scale is significantly different. The print paper size is the same as set in Composition properties.

Is this a bug or am I doing something wrong??

I'm using QGIS 2.2.0 Valmiera 64bit Win

3

This may be because you are using WGS84. WGS84 is a geographic projection, which means that the scale will vary based on latitude.

1 minute of longi­tude at the equator will be 1855.32m, while at a latitude of 45° 1 minute of longi­tude will only be 1314.11m.

You could try a different projection, like UTM, which is projected so that the scale will make sense. Or just used grids instead of a scale bar to depict scale.

0

Thanks, I thought the programme would handle that automatically. But even the Decorations Scalebar and the Measure Tool show different values.

I "solved" the problem by creating a scale bar vector layer, as I have to use WGS84.

  • 1
    You should move the first paragraph of your answer to a comment in the answer of @Vesanto, as you are telling him something specific to his answer. The second paragraph of your answer would be enough for other people to notice how you "solved" your question. – Germán Carrillo Jan 16 '15 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.