0

I am using ArcGIS 10.1 (SP1). I got a shapefile with polygons representing some features of the landscape in my study area. This file has been provided by a third party institution.

The coordinate system is missing spatial reference, as ArcGIS informs me as soon as I feed the file into ArcMap. I tried to use 'Define Projection' tool, but nothing happens, i.e. when I add other feature classes created by me (and that matches one another) the shapefile into question does not 'match' the rest of the layers.

Upon further inspections, I realized something that puzzles me even more. I am seeing that, if I take into account a given point in the map, its coordinates correspond to the actual coordinates in the right coordinate system (namely, ED1950 UTM Zone 33N) but are stripped of the first couple of digits. For example: 'true' coordinates of a point 439811 / 3986516, corresponding coordinates in the problematic shapefile 39811 / 86516; so, the first is missing the first digit, the second is missing the first two.

I would like to know if there is any way to fix this problem?

What I seem to understand for sure is that ArcGIS does not recognize this insane 'stripped' version of the ED1950 UTM Zone 33N.

  • 1
    Maybe this 3rd party uses a different coordinate system altogether? Did you already contact them for information? BTW The easiest way to set a projection on a shapefile is to open its properties window in ArcCatalog, and set it on the 'XY Coordinate System' tab. – Berend Jan 16 '15 at 9:32
  • I had hard time in trying to get in touch with the institution, and I got no reply to date. The problem is that the spatial reference does not correspond to a 'regular' coordinate system, but to an existing one stripped of some digits. – NewAtGis Jan 16 '15 at 9:36
  • Are all the points offset by the same amount, 400000 / 3900000? i.e. are they all missing a leading 4 and 39? If they're just using a different origin then you can correct the data or create a new projection with the different origin, otherwise there is lost information that probably can't be automatically recreated. – Martin Wilkerson Jan 16 '15 at 10:54
  • Please backup a copy of your data (save as they acquired) and apply different test projection on the COPY of the data- i got same problem and solved by datum transformation. Case of stripping of two leading digit is interesting, check is it co-incidental or for entire extent of map. – SIslam Jan 16 '15 at 11:00
  • 1
    There's a large (and critical) difference between setting a coordinate reference and projecting a dataset. Your description does not provide both coordinate references (source and destination), which makes it more difficult to answer. – Vince Jan 16 '15 at 11:43
2

I'm going to put this as an answer, but I'm making several assumptions so this may not be the 'right' answer! This will prove whether or not the values are ED1950 UTM 33 North but with the leading digits stripped off.

  1. Delete any coordinate reference system from the problematic shapefile. A very easy way to do this is to delete (or rename) the .prj file.

  2. Add the shapefile and your reference data to ArcMap.

  3. Make sure the data frame's coordinate system to ED1950 UTM zone 33 North.

  4. Modify or edit it by changing the following projection parameters: a. Set the false easting value to 100000 m b. Set the false northing value to -3900000 m c. Also change the name; add _mod or something.

  5. Okay all dialogs.

  6. If this is the correct coordinate system, the reference data will be projected on-the-fly (in-memory) and line up with the shapefile.

  7. If it works, export out the shapefile (right-click it in the table of contents) and select use data frame's coordinate system.

However, as other commenters have mentioned, it's possible this data is in a completely different coordinate system. (should be a comment) Can you tell us what country the data falls in, and/or from what agency you got it?

Note: The define projection or changing the coordinate system via the data's property page in ArcCatalog updates the metadata only. These workflows don't change the data's coordinate values nor extent, so the data has to be already in the coordinate system you're setting.

  • Sorry for coming back to all of you late, and thanks for your reply. @mkennedy:thank you for the step-by-step guide, which I will test next week since my data are on my workstation at my office. Your suggested 'test' pending, I wish to make clear a couple of things I was not clear about. The original problematic dataset lacks any .prj file. Yet, when I open it, some coordinates show up in the arcmap bottom right corner, with unit 'unknown'. Nonetheless, by taking into consideration a given point on the map, it can be see that the coordinates are the same of those I get for the same point.... – NewAtGis Jan 16 '15 at 17:58
  • ...in another 'correct' layer whose coordinate system is the one I indicated in an earlier post of mine. The difference is that the initial digits (again, see earlier post) are stripped out. Additional question: with reference to the answer of @mkennedy, I am wondering how can I perform the step 4, i.e. making the indicated editing. I never happen to tackle the problem. Thanx again. I will be back early next week. – NewAtGis Jan 16 '15 at 18:03
  • The UI has changed since 10.1 and I don't have that version installed. Try right-clicking the coordinate system. – mkennedy Jan 16 '15 at 18:33
  • I got a reply from the institution who provided the data. As expected, the pointed out that 'The spatial referencing system used on the MapServer is based on UTM grid coordinates. Note however that the leading 4 in the Easting and the leading 39 in the Northing have been stripped.'. Now, my main problem is how can I restore the lost digits? I mean, is there any file storing the spatial reference which can be edited by hand (or by any other means)? – NewAtGis Jan 19 '15 at 12:56
  • It's a shapefile, so should have a .prj file. You can edit it by hand as it's a text file. – mkennedy Jan 19 '15 at 14:37
0

With help from @mkennedy, I am posting a reply with some details just in case someone will jump here in the future.

I do not know why, but the shapefiles they provided were without .prj file, yet they infomed me that the coordinate system used was a stripped version of ED1950,UTM-zone33N.

I managed to fix the problem by the following steps:

  1. attribute the ED1950,UTM-zone 33N to the shapefile by using the arcGIS 'Define Projection' (which, as explained in arcGIS's help, has to be used 'for datsets that have an unknown or incorrect coordinate system defined');
  2. this will create a .prj file among the files relative to the shapefile;
  3. open the .prj file in a text editor (I used notepad++), and set false easting value to 100000, false northing value to -3900000;
  4. save and close the edited file

Now the shapefile should be projected correctly. At least, this is how it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.