I'm creating a map in QGIS Composer that is the result of two merged layers. The legend (screenshot below) is adding two rows with the titles of the layers. The edit property sheet does not give me an option to remove one of these - the minus symbol is grayed.


I can remove the con07 layer, but the desired layers are children of the Assembly_India layer (next screenshot), so I don't see how I could remove it from the original map.


I'm sure this is a very basic principle of QGIS that I am missing here. How can I remove the "con07" and "Assembly_India" rows from my legend?

1 Answer 1


Uncheck the "auto update" box. This makes it possible to remove fields from the Print Composer without removing them from the project.

You can't remove a parent without removing the children. However, you can click the Edit Text (pencil) icon, erase all the text, and the legend will eliminate the whitespace.

EDIT for QGIS 3: The "erase all the text" method no longer works. Instead you should right click on an item that you would like to hide and check the box for "Hidden". See discussion here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.