2

I'm using FME Desktop 2014 SP1 to create a rather huge mapping process from ArcSDE Feature classes to INSPIRE GML Writer. After saving the Workspace and reopening it a couple of days later, all Transformers and also some readers were gone.

I opened the workspace file with notepad++ where I could recognize some of the disappeared transformers information, but it was commented out with #

I also tried to save the workspace under different names, but every time the same happened.

I think it should be possible to recover the transformers by manually deleting '#'s but that's no suitable solution to keep on working on my workbench.

Had anybody issues like these or knows a solution to this?

2

Did you upgrade your FME in the time between editings? I recently had a 2014 workspace that, when I opened it in 2015, all I got was an empty canvas. It turned out to be some characters in annotation objects that could not be parsed (not sure the exact reason).

Anyway, as Jonathan says, send it to our support team and we will get the developer to take a look at it. I am sure it can be fixed... as long as you haven't made any manual edits. You definitely don't want to start editing fmw files by hand.

For the record, the upper "half" of an fmw file is XML(ish) that defines the workspace in Workbench; i.e. what objects are where on the canvas and how they are connected, etc.

The lower half of an fmw file is Mapping File code. This is the part used by the FME engine when the workspace is run. Every time you edit the workspace in Workbench, both parts get updated.

So you'll see that it's not easy at all to manually edit the file. If you make changes to the upper half only it won't affect how the workspace is run, and if you make changes to the lower half only then it won't affect how the workspace is depicted - plus the lower part gets entirely regenerated as soon as you open the file in Workbench and make a change.

Basically it's not practical to make manual edits to the file contents. If you ever think your file has been corrupted like this, please do send it to our support team asap and we'll probably be able to figure out how to fix it.

  • Interesting explanation of the structure; thanks for sharing! – GIS-Jonathan Jan 19 '15 at 16:38
  • Hi Mark! Thanks for the explanation. Basically I forked it from the INSPIRE Example Workbench for Aerial Transport Network from FMEpedia and edited it as said with FME 2014 SP1. I already sent it to our local distributer. I really hope that there is a chance to repair it, as it was a hard bit of work so far. I'll give it a try to remove some or all of the annotations and let you know if this helps. – Jürgen Zornig Jan 20 '15 at 7:09
  • 1
    We (Axmann GmbH.) were able to find the reason of the problem, as I was using a diacritic letter (german 'ü') in one of the Annotations. After removing/replacing these, the workbench opens and works as expected. This is only happening with FME 2014 and is afaik fixed in FME 2015. Thanks for the infos you provided and keep up the fantastic support! – Jürgen Zornig Jan 20 '15 at 11:03
2

Trying to manually parse and alter the .fmw files is almost certailing a losing proposition.

Lines starting #! in a FMW workspace aren't necessarily a comment. As you've figured out, they are a comment within TCL (the language of a .fmw file), however you'll see that actually almost all the lines that start #! actually look like XML. I believe that FMW files contain a combination TCL, and commented-out XML within that and that this is intentional.

Looking at several of my workspaces, the first 4/5ths of the file are consistently of this #! XML structure.

The last line of this XML section is: #! </WORKSPACE> after which normal TCL starts, and anything commented out there is likely an actual comment.

I'd suggest it's worth emailing your support and having them look into it; it may be a bug. May also be worth upgrading to a newer version of FME.

  • Thanks for the info, that these aren't necessarily comments. Didn't know that. I also tried to uncomment these lines but that didn't change anything on the behaviour. I opened a support ticket for this, and now hope that 40 hours of work on this workbench weren't for nothing. – Jürgen Zornig Jan 19 '15 at 12:28
  • @JürgenZornig - No problem. Note that FME 2015 has a "History" tree. That may help identify what happened. Not sure if you can use it with old workbenches yet; not really given 2015 a proper go. – GIS-Jonathan Jan 19 '15 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.