5

I'm trying to create a virtual raster in QGIS 2.6.1 64b on Windows, but I get the message:

"The process failed to start. Either the invoked program is missing, or you may have insufficient permissions to invoke the program."

I try to read in a whole directory, selecting also to "Recurse subdirectories" it works for a part of my datasets, but not for all. I thought it is related to the the size of the datasets, so I tried dividing the bigger datasets in smaller directories. but it did not work.

  • 1
    Are you running as an administrator or a regular user? Try running QGis by right clicking on the icon, then use "Run as administrator" see if that makes any difference. – shawty Jan 19 '15 at 14:37
  • 1
    I am running windows as administrator, I tried also starting QGIS with the right click "run as admin" but it does not do the trick – Meto Jan 19 '15 at 15:04
  • Ok, next thing to check is to select ALL the files in your data set, right click, look at the security and make sure all of them are readable by the user your logged in as. – shawty Jan 19 '15 at 22:03
  • I know this was asked a while ago but I just ran into the same problem trying to make a vrt out of 1300+ files. There must be a character limit or some kind of limitation in the "Build Virtual Raster (Catalog)" tool. Because when I copy the text from the GDAL code box at the bottom of the tool and paste it in the command line my text stops midway through the reference to file 1076 (out of 1300). So as @radouxju suggests if you edit the command and execute via the command prompt you might have better luck - It solved my error. – Andrew Jeffrey Apr 22 '17 at 5:37
3

virtual raster in QGIS comes from the gdalbuildvrt. You should try to locate gdalbuildvrt on your computer and run it from the command prompt. Size should not be an issue at all because this is what virtual raster files are for. Below is the (simplified) syntax of gdalbuildvrt

gdalbuildvrt [-resolution {highest|lowest|average|user}]
             [-te xmin ymin xmax ymax] [-tr xres yres] [-tap]
             [-separate] [-b band]* 
             [-r nearest,bilinear,cubic,cubicspline,lanczos,average,mode}]
output.vrt [gdalfile]* 

so the basic command line line will look like this

gdalbuildvrt -overwrite output.vrt input.tif 

the -overwrite option delets existing file with the same name as the output.

the easiest way (in my humble opinion) to install gdal is to use OSGEO4W installer. You should the have an osgeo4W shell from where you can launch your commands. Note that this couls also help you update your QGIS and make sure that gdal links are well defined.

  • Can you detail how to "run it from the command prompt"? Thanks – Rashomon Jul 3 '18 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.