0

enter image description hereenter image description hereUsing QGIS 2.6.1 Brighton on an IMac (10.8.5). QGIS 1.8 Lisboa with exactly the same two vector shapefiles and the same CSV file works. I joined the file containing the polygons showing the features on my archaeological site to the csv file. Used the query function and in 1.8 all of the features stay the same color except those that match the criteria. They turn another color. I can then save that layer.

In 2.6.1, the same procedure results in my being able to individually select a single feature and all the rest disappear. Presumably that's a new feature in this version and that's fine. But if I use any of the database material in the csv file as a search criteria, it tells me nobody's home, which is obviously not the case. I've tried on several different headings with the same result.

I've completely uninstalled QGIS and all of the associated files, downloaded the latest and still have the osgeo problem of not loading despite it saying that it references 1.11 as it should.

Any ideas on how to fix this?

  • 1
    2 options I think. Set up the join then save the layer which I think includes the joined data permanently or copy the columns across using the field calculator then remove the join and do your queries. I have had similar issues - every version of QGIS has something new to tackle but the price is right. – Sethinacan Jan 19 '15 at 21:52
  • Please post details about the query you are using and the column names. Best take screenshots. One differenct between 1.8 and newer versions is that the table name is prepended to the attribute names in the new verions. – underdark Jan 19 '15 at 22:38
  • Understood about the prepending of attribute names. Here is the heading list for the AT. – Lyle Browning Jan 20 '15 at 2:57
  • Headings and Query example added to original. In query, whatever I used worked only on the F column. For others, I get zero or "OGR[3] error 1: Type mismatch or improper type of arguments to LIKE operator. – Lyle Browning Jan 20 '15 at 3:15
  • Are you using the query in Layer Properties | General | Query Builder? For me, this feature is grayed out for layers with joins. Select by expression for example works perfectly fine with joined columns and LIKE queries. – underdark Jan 20 '15 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.