1

Model

I am running a join in model builder based on a calculated field in a geodatabase table and a created layer. After the join I am selecting features and copying selection to a new Shapefile.

My issue is that during the join the resulting joined layer has all field named using the LayerName.FieldName naming convention. I have tried both checking and unchecking the environment setting of "Maintain Fully Qualified Field Names," however, neither are working. Only way I can seem to fix it is to manually delete and rename the fields during the copy features process.

Wondering is there a specific modelbuilder setting/tool/process I can use to only keep actual field names.

0

The tool Copy Features honours the qualified field names environment setting. So Use that tool to make a copy of the dataset with the join and work with that.

  • Hornbydd, thank you very much, using the copy features tool right after my join worked! Thanks – ZachS Jan 20 '15 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.