Recently I worked on adding a custom toolbar to ArcMap. It took a few tries, and now there are my initial 'drafts' of the toolbar still added to my ArcMap list of toolbars. According to the help, I should just be able to delete them. However, the Delete button is grayed out when I try to select my custom toolbar, as if it were one of the default toolbars. Has anyone else had this problem and come up with a solution?

enter image description here

3 Answers 3


I have found the solution:

In the dropdown menu: Customize -> Add-In Manager...

And then, highlight add-in and click 'Delete this Add-In'

enter image description here


These are those strange situations where ArcGIS may have just locked itself. Have you tried closing all of your Arc products and then restart to see if you can delete? Maybe go as far as to do a restart of your computer to make sure all ArcGIS processes have been killed?

  • Sadly, this situation has persisted for months. Jan 20, 2015 at 22:59
  • I figured as much. This is weird. I remember having the same issue a couple years ago and I know I resolved it, but I just can't rememeber how. I'll post up if it comes to mind.
    – Mike
    Jan 20, 2015 at 23:01

If you know the dll for the toolbar or custom tool, try using ESRIRegAsm.exe,. It is located in the ~:\Program Files\Common Files\ArcGIS\bin folder. (OR c:\Program Files (x86)\Common Files\ArcGIS\bin)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.