2

enter image description hereWhen I load a plugin in QGIS ,met some problems :

I had tried copy other Python27's files to QGIS's Python 27 file but it still does't work.


Couldn't load plugin PRISM due an error when calling its classFactory() method

Traceback (most recent call last): File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 164, in startPlugin plugins[packageName] = package.classFactory(iface) File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins\PRISM__init__.py", line 25, in classFactory from prism import PRISM File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins\PRISM\prism.py", line 15, in import numpy File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\numpy__init__.py", line 137, in import add_newdocs File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\numpy\add_newdocs.py", line 9, in from numpy.lib import add_newdoc File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\numpy\lib__init__.py", line 4, in from type_check import * File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\numpy\lib\type_check.py", line 8, in import numpy.core.numeric as _nx File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\numpy\core__init__.py", line 5, in import multiarray File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py", line 309, in _import mod = _builtin_import(name, globals, locals, fromlist, level) ImportError: DLL load failed: %1 ���O���Ī� Win32 ���ε{���C

Python 版本: 2.7.5 (default, May 15 2013, 22:43:36) [MSC v.1500 32 bit (Intel)]

QGIS 版本: 1.8.0-Lisboa Lisboa, 6416f38

Python 路徑: ['C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python', 'C:/Users/corbies/.qgis//python', 'C:/Users/corbies/.qgis//python/plugins', 'C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins', 'C:\Program Files\Intergraph\ERDAS IMAGINE 2014\usr\lib\Win32Release\python', 'C:\WINDOWS\SYSTEM32\python27.zip', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\DLLs', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\plat-win', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\lib-tk', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\qgis\bin', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages', 'C:\Program Files (x86)\ArcGIS\Desktop10.2\bin64', 'C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy', 'C:\Program Files (x86)\ArcGIS\Desktop10.2\ArcToolbox\Scripts', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\PIL', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\win32', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\win32\lib', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\Pythonwin', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\qgis\python\plugins\fTools\tools']

I think that the plugin designed for QGIS 1.8-1.99

1

The plugin is not in the official repository.

You have to make sure that it will work with QGIS 1.8. Most plugins are designed to run with QGIS 2.0 and later only.

  • I think that the plugin designed for QGIS 1.8-1.99 – 楊宇恩 Jan 21 '15 at 7:55
  • DLL load failed might be a clue, but you better contact the author about it. Maybe some extra DLLs are needed, or the blanks in the folder are bad. – AndreJ Jan 21 '15 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.