1

beside other tools I am using the dissolve tool in a python script. The input feature class (polygon) has about 140 MB. Running the script with python 32 bit (in CMD and in ArcGIS Desktop 10.2.2) fails due to memory problems. Of course the script succeeds with python 64 bit (only in CMD). Well, I made some tests:

  • If I start the dissolve process manually using the "standard" Dissolve Tool (Generalization Toolbox) in ArcGIS Desktop (using 64 bit Background Geoprocessing), the ArcMap.exe uses 200-300 MB RAM, the RuntimeLocalServer.exe uses about 1 GB RAM. Hence, everything is fine with 32 bit. The process succeeds.
  • If I integrate the Dissolve Tool in the Modelbuilder and start the model, the RAM that is used by ArcMap.exe is raising up to 1.2 GB, the RuntimeLocalServer.exe seems to be inactive (No background geoprocessing?). However the tool succeeds.
  • If I start the tool via python script in the command line (or executed in an own Toolbox in ArcGIS Desktop), the ArcMap.exe process is raising up to 2.7 GB RAM and, of course, it fails with python 32 bit.

Why does the same tool with the same input data have a different use of memory in context of ArcMap Toolbox, Modelbuilder and python script via CMD (arcpy)???? Currently I have to run the script with python 64 bit via CMD because the memory is exploding if the script runs within an (own) ArcGIS Desktop Toolbox. Unfortunately I have to change also some other tools (e.g. ET Geowizards) that are not running under 64 bit, too.

Does anybody have an idea why the use of memory is "low" if this tool is only running with 32 bit using the ArcGIS Toolbox?? (or the other way: why is the memory exploding if I am not using the data management/generalization/dissolve tool?

  • I'm having the same issue. The dissolve just freezes when I run my script in PyScripter, but it works just fine on the same data when I run it from the command line, as a tool in ArcMap/Catalog, or when I run the script by double-clicking. PyScripter is set to run 32-bit, but then why does it work in the PyScripter command line? – Tom Aug 10 '15 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.