This is a very device-specific question but maybe someone has ideas.

Our problem is that we cannot import files into our File Geodatabases that are stored on a NAS device. When the import function is run, only an empty table is created and no data is transferred.

Error messages attached.

I can:

  • Create new File Geodatabases on the NAS device
  • Create new data within file Geodatabases on the NAS from Catalog
  • Export data from a file Geodatabase to the NAS
  • Import data into a local Geodatabase

There's a lot out there about Geodatabase locks (which seems to be the issue) but nothing I can tie directly to this issue.

Hardware/Software info:

  • NAS = QNAP TS-453 Pro (latest firmware installed)
  • ArcGIS software 10.2.1
  • Platform Windows 7 Professional 64Bit

enter image description here

  • 2
    Shorten your filename to less that 14 characters - ArcGIS does not like numbers at the start either.
    – Mapperz
    Commented Jan 21, 2015 at 19:29
  • This is problem emerged only recently after years of using this identical file structure. ArcGIS doesn't like Rasters that begin with numbers but it doesn't care about folders. I've tried tests at the very base of the NAS so file name length is not an issue.
    – RichT
    Commented Jan 21, 2015 at 19:50
  • Solution is to disable windows firewall.
    – RichT
    Commented Jan 22, 2015 at 17:42

2 Answers 2


We have similar problems with the geodatabases on NAS. In our case it mainly depends on if several people work at the same time with the same geodatabase.

Normally it helps to

  1. delete manually all lock files and
  2. actualize the database by a right click and refresh (F5)

arcgis refresh

If that's not helping it usually the last step is a restart of ArcGIS.

Still we have for some users problem the geodatabases but usually the user who has create the database has the smallest problems.


Disable windows firewall. While not a great solution because of vulnerability, it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.