1

i have a problem with importing my shapefile to postgreSQL, it's a poroblem with the encoding, here's the screenshot: Import failed

i tried to change encodingin "options" buti get this message:

"Failed in pgui_exec(): ERREUR: séquence d'octets invalide pour l'encodage « UTF8 » : 0xe3 0xa9 0x72

Shapefile import failed. "

Do i have to change the encoding in arcgis?and how?

thnks in advance

3

Before you start importing in the Shapefile-loader click on the "options"-button and there replace "UTF8" with the correct encoding.

  • I did it alread, but i get this error "Failed in pgui_exec(): ERREUR: séquence d'octets invalide pour l'encodage « UTF8 » : 0xe3 0xa9 0x72 Shapefile import failed" – Geographic Jan 25 '15 at 20:15
  • Did you load the Shapefile in a desktop gis like QGIS before and checked if the characters (franch "accents" etc.) are displayed correctly in the attribute table? – Thomas B Jan 25 '15 at 21:02
  • if you don't know the encoding of the shapefile you could also try to import it with the shapefile loader using some common encodings like CP1252, IBM850 or ISO8859-15. – Thomas B Jan 25 '15 at 21:09
2

Based on the answer to Which character encoding is used by the DBF file in shapefiles?:

To change the encoding of a DBF open it with OpenOffice Calc.. choose SaveAs... click the "Filter options" in the bottom left and press save. You can then define the encoding to convert the text contents into.

As you may already know, feature attributes of your Shapefiles are stored in a DBF file. Go to the folder where the Shapefile is located and you see the DBF file. You can get OpenOffice Calc (or better yet, LibreOffice Calc from here).

Concerning field names of your Shapefile, from the same answer:

Attention: All this only applies to the data, not the column names. You should really only use ASCII in the column names of a DBF if you want the file to be openable with other programs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.