1

I'm working on a class project where we make a pie chart out of an attribute table. The attributes are geologic layers (UNITNAME), and the area they occupy (area_pct). In the "Create Graph Wizard", I have selected the correct table, and set the value field to "area_pct" and the label field to "UNITNAME". However, I can't get the sort field to let me select anything. I want the sort field to be "UNITNAME" as well. I managed to get it to work yesterday by goofing around with the options, but I honestly have no idea how I did it, and now I can't replicate it.

Does anyone have any suggestions? Is this arcGIS (10.2.1) just being picky as usual?

closed as off-topic by PolyGeo Nov 16 '16 at 0:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • From what I understand, you want to sort the pie chart based on a text field? I believe the sort field must be a numeric value, so that It can be ascending or decending – Martin Jan 27 '15 at 20:47
  • That makes sense to me. Except that I got it to sort by UNITNAME once, so I know that somehow it is possible. What I wound up doing is ignoring the sort field, generating the pie chart, and then going in to Advanced Properties - Data, and manually entering the attribute names. Luckily for me, there were only 6. If anyone did a pie chart similar to this, but with many sections.... it would become a hassle. – Charlie Jan 28 '15 at 0:08