My company have upgraded to to Mapinfo 12.5.1 (64-bit) this week. It fails to open tables that call *.xlsx files. Those that call *.xls files have no problem. The error for *.xlsx files is as follows:

enter image description here

If I attempt to open *.xlsx files in this new version of mapinfo (to register them as tables) I get the following error.

enter image description here

The *.xlsx files I am trying to call/open are not being used by any other application, nor are they located in a read-only directory or similar.

Suggested solutions on this forum to similar errors suggest converting *.xlsx files to *.xls format. We have hundreds/thousands of tables that call *.xlsx files, so this would be a major undertaking. Furthermore, I wonder that this may be something different and specific to mapinfo 12.5.1 (64-bit), as the same tables (from the same location) open without issue on earlier versions (e.g. mapinfo 12.5.0).

I hope someone may have a smart solution... :)

2 Answers 2


The release notes for the 64 bit version state that:

"MapInfo Pro is a 64-bit application that can access spreadsheets and tables from Microsoft Excel and Access. To use data from Excel and Access within 64-bit MapInfo Pro, you must use the Microsoft Office 64-bit driver. As part of the MapInfo Pro installation process, the 64-bit Microsoft Access Database Engine 2010 Redistributable for Office is installed if the Microsoft Access Database Engine 2010 32-bit driver is not already installed on the system. The effect of this is, if 32-bit Microsoft Office is already installed on the system, the MapInfo Pro installation process will not install the 64-bit Access Database Engine drivers necessary for 64-bit MapInfo Pro access to Excel and Access."

In short, to open xlsx files on 64 bit MapInfo you must have the 64 bit Microsoft Office drivers installed. The release notes have some additional information on how to determine which version of the Office drivers you have installed and how to concurrently install both 32/64 bit drivers.

  • Thanks for your information. My colleagues contacted Pitney Bowes about the matter - my company have a maintenance license for Mapinfo. I'm told that PB have commissioned Microsoft to engineer a fix that lets 64-bit mapinfo open *.xlsx files on a machine with 32-bit office. We have deployed it and it seems to work a treat. PROBLEM SOLVED. I cannot vouch that this fix is available to PB's non-maintained customers... Perhaps others affected should contact Pitney Bowes for similar solution (their support is a freephone number in the UK!).
    – Tim Harper
    Commented Feb 2, 2015 at 10:07

I had the same problem and received these step by step instructions from Pitney Bowes Support:

  1. Download the MS Office drivers from http://www.microsoft.com/en-ca/download/details.aspx?id=13255 The 32-bit version is AccessDatabaseEngine.exe. The 64-bit version is AccessDatabaseEngine_x64.exe.
  2. Uninstall the 64-bit Office driver, if installed, and reboot the system. You will already have it installed if you have installed MapInfo Pro 64-bit.
  3. Install the 32-bit Office 2010 driver.
  4. In the System folder (for example C:\Windows\System32), right-click on cmd.exe and select Run as administrator.
  5. At the command prompt navigate to the folder where the 64-bit Office 2010 driver is located by typing in 'cd' followed by the directory then hit ENTER as illustrated in the screenshot below.
  6. Type the command and press enter: AccessDatabaseEngine_x64.exe /passive (as illustrated in screenshot below) Both drivers are now installed on your system.
  7. Restart MapInfo Professional v12.5 64-bit and open xlsx file to double check if it works

After following these instructions I was able to open an excel file, but then I kept getting a "One of yoru object libraries(|) is missing or damaged. Please run Setup to install it." error upon opening Excel. To fix it, I received the following again from Pitney Bowes Support:

Open the registry editor (Start > Run… then type “regedit”) then look for a registry value called "mso.dll" under the key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths". If it is there then delete or rename it. Close the registry and restart the machine.

After that, everything worked fine.

  • You are very welcome to add your signature details into your user card which signs every post you make here.
    – PolyGeo
    Commented Feb 14, 2015 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.