5

I am trying to export a map from QGIS print composer but the resulting files (I've tried all image, .svg, and .pdf formats) do not appear as the map did in the composer.

It is as if one of the raster layers (an elevation model) has just not been included although the other raster layer (a hillshade layer) has worked. Every other layer, all vectors, appear fine.

Below is a screenshot of how it looks in the print composer. The topography colouring is from the elevation model raster layer, the hillshade is a semi-transparent layer above it. screenshot of composer

Here is what the resulting export looks like. This is also what it would look like if the elevation raster wasn't present at all. resulting export

Has anyone come across this problem before? I'm using QGIS 2.6.1 but have also tried the recent 2.7 dev version.

Edit (2017-03-07): Prompted by the latest reply I tried to recreate the issue that I had which hadn't been solved by any of the previous answers. I was unable to recreate the problem despite attempting to export at a range of resolutions and file types. I assume it must have been a memory problem as suggested by Juan which has since been fixed (I am now using version 2.18.3) but I cannot be sure.

  • I have the problem that: I create a map composer template and export the map as pdf or a figure all layers are exported. But when I use the template in a python code to apply it to another set of data, one layer is missing. I played with the transparency levels but no success. Any idea why this is happening? – wided Jul 14 '15 at 15:15
  • Welcome to GIS.SE. Please ask another question, but don't leave questions as answers. – John Powell Jul 14 '15 at 15:57
3

I had an issue similar to the above, and also similar to this:

http://osgeo-org.1560.x6.nabble.com/Print-Composer-Rotation-of-Shapefiles-with-transparency-td5100394.html

I finally fixed it in the style box of the Layer Properties - I set the transparency in the top Layer Rendering box to 0, and instead changed the layer transparency in the symbol colour box to the % I wanted, and suddenly the whole semi-transparent layer rendered, instead of just a portion. I was using Windows 7, QGIS 2.0.1. It was a very frustrating thing, to have Print Composer window perfect, and when you hit export half your layer disappears!

  • This is absolutely the answer and sorted out a problem I had just now. A layer sitting on top of the relevant layer for my composer, that was covering the print version even though it was turned off. Thanks! – Ben MS Mar 23 '16 at 4:30
1

Check to see if you have scale dependent visibility on in the layer properties general tab.

  • Thanks for the reply. No, I don't have scale dependent visibility selected although I did fiddle around with it to see if I could force the layer to appear but no luck. – WMoreland Feb 3 '15 at 10:45
1

I had exactly the same issue with a very high resolution raster, and I solved it by exporting as an image at a lower DPI. However I could not find a way to export it at 300 dpi as I originally wanted (150 dpi was the max). I guess it is a memory problem, and not sure how to sort it out.

1

I ran into this, in my case it seems to be some kind of caching problem. I have a vector layer (SpatiaLite) with point data which does display in the print composer preview, but is then absent in the exported image (png).

I tried saving at lower resolutions (150 and 100 dpi instead of 300), to no effect. None of the layers have scale-dependent visibility or transparency settings.

I noticed that occasionaly the same layer would also disappear in the main project window after coming back from the print composer, and reappear after disabling and enabling it again. Occasionally the layer would also disappear from the print composer preview.

In the end what worked for me was just saving and closing the project, then opening it again, go straight to the print composer and export to image.

Note: the occasionally disappearing layer comes from a SpatiaLite database with many points (about 500k), but only a few dozen are rendered (queried via a provider feature filter). The system has plenty of memory (16GB), and the layer does not display any performance problems while working with it generally.

  • Saving, closing & re-opening worked for me with a raster that was not appearing in Print Composer! – Amroco May 31 '17 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.