3

I'm new to QGIS, so supect this is trivial, but it has frustrated me for the last hour or more... Last week whenever I added a csv as a layer once I'd filled in the first dialog it automatically opened a dialog where I could select the correct CRS. Today when I open a CSV file I go straight from the open CSV dialog to the map with a warning flagged at the top that the CRS was not set so it has used the default value, which is wrong. I must have somehow clicked some setting somewhere that has turned off the (very handy!) dialog and I can't find it anywhere. What have I done wrong and how can I get QGIS to automatically open the dialog again?

  • You can always set the layer CRS by right-clicking on the layer and selecting Set Layer CRS. Ofcourse this doesn't answer your question, just a little tip. – Joseph Jan 30 '15 at 11:02
1

There is an option here which should prompt users for a CRS when adding a new layer via:

Settings > Options > CRS

CRS options

Hope this helps!

  • That was exactly it. I've not seen that box before, so puzzled about how I turned this off, but nevermind. – CMB Jan 30 '15 at 11:11
  • Awesome! And don't worry, sometimes QGIS likes to play games with users :) – Joseph Jan 30 '15 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.