3

I have a problem with using Arc Hydro. I tried to follow these steps:

  1. App utilities> Set target locations

    • Raster Data: C:users\seabell\Deskop\weekdata4\

    • Vector Data: C:users\seabell\Deskop\weekdata4\untitled.gdb

  2. Fill sinks
  3. Flow direction
  4. Flow accumulation
  5. Stream definition: I gave the number in area
  6. Stream segmentation
  7. Catchment grid deliniation
  8. Catchment polygon processing

I receive an error which is:

Error HRESLT E_FAIL has been returned from a call to a om Component

Can anyone help me?

  • What step did you hit that -- I assume 8? As a general comment, I found it was less buggy to use ArcHydro via the toolbox than the menu bar; that may or may not get you to the next step! – Erica Jan 30 '15 at 13:04
  • See this video may help you in your problem youtube.com/watch?v=DK34C7QScRU&feature=youtu.be – bassim.s.shama Dec 20 '16 at 3:38
  • I have had same problem but I think I solved. I tried over and over.. 1- My dem is "geo-tiff" 2- folder location: in root, direct local disc C: or D: exaple C:\a\ 3- Folder and file names are shortly. exaple mxd name is "hydro", dem name is "DEM", not two word, short and one word, especially no gap. 4- When I describe "Set target locations for HydroConfig" raster data is ok. but, if vector data is "mdb" , It was not. I described vector data "gdb" (File Geodatabase) good luck – IBRAHIM GEDIK Feb 15 at 19:51
4

It appears that this is a fairly common error encountered when ArcHydro is run with data between the network and the local C: drive. See this site for further details:

https://geonet.esri.com/thread/89781

The solution seems to be in where the data are stored.

  • As stated above, it could be a data storage issue. I used these tools pretty extensively at my last job, and the data storage was definitely key. I would suggest putting all of the data in a single .gdb – Tangnar Jan 30 '15 at 14:29
  • Thanks for the advice. I deleted all my file and I did whole process again and I got the results. But when I look my vector data, projection is undefined but when I started to delineate, projection has already defined. i don`t understand that why I need to include projection again? – seabell Jan 30 '15 at 16:50
0

Solution: This is done using 10.6, I am not sure if it works for other version. Open toolbox => Arc Hydro Tools Python => Terrain Preprocessing => Catchment Polygon Processing (or whatever raster to polygon you are choosing).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.