0

If I connect to my campus network, the map is not showing any data dots

If I connect to my campus network, the map is not showing any data dots. And from the screenshot you can see the error messages.

If I use any other network, for example using my phone's hot spot, it is fine

If I use any other network, for example using my phone's hot spot via att lte, or comcast from my home, it is fine.

Any one knows what is happening?

  • I've had similar problems with my home network and networks outside my home... also: please give a bit more information as to the system you're using (CartoDB) and what you're working with (Visualization) – DPSSpatial Jan 30 '15 at 22:12
  • Thanks for your quick response. But I don't understand what kind of "system(CartoDB)" are you referring to. – jack2684 Jan 30 '15 at 22:20
  • you didn't explain what this map is, how it was made, where the data is coming from, how you've built this app, etc. – DPSSpatial Jan 30 '15 at 22:26
  • So this is a map about some food energy system around the world, with coordinates and corresponding names, descriptions. I upload an excel file to create a table. Then I visualize it with cartodb visualize queue. At last, I copy autom-gernerated iframe code into my own wordpress page. – jack2684 Jan 30 '15 at 22:45
  • This seems to be provoked by a firewall blocking the tiles. Could you try to embed the map via HTTPS? Remember that for that you need to modify the URL of the libraries. – iriberri Feb 2 '15 at 9:25
0

iriberri is correct. I need to specify protocol in the options field, like this.

cartodb.createLayer(map, layerUrl, {'https':true})

Whiel the layerUrl is not necessarily https.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.