* Connected to ascendxyzdatastagingweu.blob.core.windows.net ( port 443 (#0)
* libcurl is now using a weak random seed!
* SSL certificate problem: unable to get local issuer certificate
* Closing connection 0

I got the above eror with vsicurl and gdal and was not able to find any solution on google.

What is the tasks to enable gdal to use vsicurl with https?

  • 5
    Your certificate is obviously not from a trusted provider. Try what happens if you add --config GDAL_HTTP_UNSAFESSL YES into your command.
    – user30184
    Feb 1, 2015 at 22:14
  • The SSL is from microsoft blob storage. I would like to find a solution taht dont disable ssl Feb 1, 2015 at 23:40
  • I suppose you must add all missing certificates from the trust chain into the CA cert bundle curl.haxx.se/docs/sslcerts.html.
    – user30184
    Feb 2, 2015 at 5:31


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.