2

It's really horrible I must say. I sometimes have geometry issues and then try to go one by one through them and fix these cases. Therefore I mark the area points and delete them for instance. After that I doubleclick the line to create a new point. And now I often have the issue that by dragging this point I create a green circle at that position instead of just moving the point.

I would like to know why I often cannot move it and am getting these green circles instead. Also, if this is a feature, what are the green circles good for, I was thinking that sign is showing duplicated points? And the last question is, why does the point movement sometimes work, but in 80% of cases it does not?

Here a picture to make my issue a bit clearer:

enter image description here

  • Mabe your double-click inserts two new vertices, not just one. – AndreJ Feb 4 '15 at 6:10
  • Yeah seems like a bug. But as I said in my answer, a restart of QGIS helped out. I will have an eye on it in the future. – kwoxer Feb 4 '15 at 7:45
5

The green marks indicate that you have created a topological error.

For example, when you "cross your own path" and create a geometry that does not make too much sense anymore.

Consider this:

Step1: Everything is still OK now:

enter image description here

Step 2: Now you are about to create an error:

enter image description here

Step 3: And, whoops, there the error is, and it is marked in green:

enter image description here

You most likely did not mean to create that that gap, and therefore QGIS warns you and marks the vertices that caused the gap it in green. Although the dataset is officially still ok, and it can be used in tools, once could say that in most cases it would be rejected as a "good vector" dataset.

EDIT: Green marks also appear when placing two vertices exactly on top of each other. Let's say you use the Node Tool to move one vertex, but instead of clicking and dragging it, you first double click, then it would appear in green (until you move it, that is). But now that I am testing it and it does not always happen. Perhaps the behavior is somewhat random... of I have not yet understood the logic behind it either.

  • No that's not the case. As you can see from the picture, there is no error. Or just imagine the 4 green crosses are not there and just the normal one is there. So there is no error. I just tried to move it. Your picture indeed, that would be an error. That's easy to get, but in my case it is really just moving 1 point, between two others. =/ – kwoxer Feb 3 '15 at 20:26
  • See my edit. I need to go now. Will try to look into it more tomorrow. – BritishSteel Feb 3 '15 at 20:45
  • It seems that a restart was helping out. So you don't have to go deeper than you want to. As I said I did no mistake, it was something of QGIS. And not with 6 points, it's with 4000 points ;) – kwoxer Feb 4 '15 at 7:52
  • 2
    When things start behaving too strangely then restarting a GIS can never be a bad idea :-) – BritishSteel Feb 4 '15 at 9:55
  • Without the data it is hard to be sure, but I am 85% confident you had 2 points onto of eachother on those two points. Try selecting one of those nodes, deleting it and see what happens. – HeikkiVesanto Feb 4 '15 at 13:48
1

I'm not 100% sure, but it seems that restarting QGIS helped out.

Now I tried to fix several issues in my polygons in the same way I did yesterday. But when I know doubleclick a line, it correctly creates just one point and I can move it anywhere without creating green crosses. I did this 10 times and nowhere got them now. The only thing I changed was restarting QGIS so far.

I will have a look on it if the issue still exists. Otherwhise restarting is the way to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.