1

I've been running into an issue with Erdas Imagine 2011. I have been creating training sites in a polygon shapefile to use with a decision tree classifier but it seems like the software keep automatically simplifying/removing points from the polygons I draw. This only seems to happen when I am zoomed in past a certain scale.

I've tried copying the shapefile and using 'Save As' to create a new copy but neither fixed the issue. New shapefiles created in Erdas do not seem to have this problem (although at one point I swear that new shapefiles were having this issue but have not been able to recreate it). I have also tried editing this shapefile in ArcGIS and it seems to work fine.

Before this started happening I had viewed the data in ArcCatalog. Could that have causes this issue? Is there some setting I am missing?

I attached two screen shots to try and clarify. I made both ellipses the same way (using the 'Ellipses' tool on the 'Drawing' tab). This is an exaggerated example but shows the issue.

normal

generalized

  • I found a workaround. I created a new blank shapefile and then copied the features over using the 'Copy Features' tool in ArcGIS. Creating new polygons in Erdas seems to be working fine now. I'm still not sure why this happened in the first place though. – spalka Feb 3 '15 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.