1

I am working the GeoServer tutorials from Intro to GeoServer via Packt Publishing.

I'm trying to add a shapefile via AddStore using the GeoServer GUI. I can browse to, "see" and publish shapefiles that come with the GeoServer install and are located in the GeoServer data did, but I can't "see" shapefiles I've downloaded myself, even though I can browse to the directory where they live.

I downloaded a county shapefile from the census site given in the GeoServer beginners guide, the files are consistent with the tutorial, but the directory appears empty when I try to add it via Add Stores.

Do I need to restart GeoServer? Is there a file I'm missing?

closed as off-topic by Ian Turton Feb 4 '15 at 9:10

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Ian Turton
If this question can be reworded to fit the rules in the help center, please edit the question.

  • The shapefiles you downloaded - are these unzipped from their compressed folders? – evv_gis Feb 3 '15 at 21:18
  • Yes, they are unzipped from their compressed folders. – Stephanie Feb 3 '15 at 22:55
  • I'm an idiot. I downloaded to my Mac, then used Cyberduck to upload to linux system where the files appeared to be unzipped, but invisible to Geoserver. – Stephanie Feb 3 '15 at 23:08
  • I tried doing a wget directly from my linux system and manually unzipped them there...now Geoserver can "see" them. Thanks! – Stephanie Feb 3 '15 at 23:09

Browse other questions tagged or ask your own question.