1

I am trying to split existing polygons but when I do, gaps and overlaps are created between the polygon I am cutting and adjacent polygons.

I have snapping switched on and have enabled topological editing. I also get lines appearing across the screen which then disappear if I zoom in or out.

For example in the image below the line with the red arrow pointing to it is not a polygon boundary and disappears when I zoom. Also if I delete a polygon I am sometimes left with strange dangling nodes that should not be there.

enter image description here

Achlain_Current

Restock

1

I had the same issue. You need to make sure that the polygon is free of any issues, like duplicated point or intersections.

Do this by :

  1. Select your feature
  2. Go Vector -> Geometry Tools -> Check Geometry Validity
  3. Here choose Use only selected features to make the process faster
  4. Hit OK and delete error if you have some
  5. Now retry the splitting

enter image description here

  • Thanks. I've tried this before and just did it again and it says there are no errors. I've had quite a lot of issues with this shapefile (it has almost 1000 polygons). I ran v.clean on the file a while ago and I wonder if that has created problems. – Jillian Feb 4 '15 at 16:37
  • I don't know but could you share the shp file. I mean maybe you are not using the splitting correctly somehow. You slected the feature and then just would like to split it somewhere. So you draw a line with that tool going trough the polygon. Are you really going through or selecting the endpoints of that polygon? – kwoxer Feb 4 '15 at 16:53
  • The problem happens more when I finish the split by snapping onto existing vertices but I don't understand why this should cause gaps and overlaps to appear. I'm happy to share the shapefile and very grateful for any help. How do I share it? Thanks – Jillian Feb 4 '15 at 17:04
  • I actually wanted to delete an existing polygon and replace it with others. It's an area of forestry that has been felled and I want to update the map with the restock planting. I created a shapefile for the restocking by copying the existing polygon shapes and creating a new shapefile with the expectation that the lines should be exactly the same so I could delete old polygons then copy and paste features from restock shapefile into the main shapefile but this also creates gaps and overlaps. Hence I am now just trying to cut in the shapes manually. – Jillian Feb 4 '15 at 17:07
  • Wow that was a big sentence =) Well I'm still not completely sure that I got your issue or at least what you want at the end. So I think others also having that issue with your description. Maybe upload the code to gist and add some more picture, with several steps of the preocedure. Would that be possible, thanks. – kwoxer Feb 4 '15 at 17:27
1

Even after confirming the polygon layer's validity I still found that the Split Features tool left topology errors. In my experience, ensuring that Enable Topological Editing is turned on on the Snapping toolbar prevents this from happening. Image of snapping toolbar with both Snapping and Enable Topological Editing turned on. Enable Topological Editing is also circled in red

0

You could try deleting the relevant polygons from the "Achlain_Current" shapefile and then running a Merge or Union tool with the "Restock" shapefile.

Another option is to try v.clean again on your new shapefile after you copied the polygons and run various tools such as deleting duplicate polygons, removing dangles etc.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.