1

I have been using QGIS with an Apple Magic Mouse. Despite disabling all the point and click features and gestures in the systems preferences, the maps constantly zoom in and out extremely and uncontrollably with the merest touch of the cursor to the screen. What could be causing this?

  • 1
    I have had exactly the same problem. I think its the 'scroll wheel' function by dragging the finger along the centre of the mouse. The slightest accidental finger drag zooms the map wildly. I've not worked out how to resolve, answer above doesnt seem to help unfortunately.. – user52082 May 13 '15 at 19:34
5

Although still quite buggy you can change Qgis/ Preferences/ MapTools/ and than zoom factor. You can set it to 1.1

0

Under Settings / Options // Map Tools // Panning and Zooming you can set the "mouse wheel action" to "Nothing"

This can also be used if you are using slow data-connections (like a database) so your view doesn't get rendered with every roll you do on the mousewheel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.