3

I'm sure this is a very simple task, I have a black and white basemap and i would like to remove the white from it in the latest version QGIS.

There are setting in layer properties and bands etc, but I don't know how to do it and have been unable to find a good explanation. The answer i found was for an earlier version of QGIS and the dialog box has changed!!

  • Are you saying the white are the NULL values? So the part of the raster that does not contain any useful information? – BritishSteel Feb 10 '15 at 17:39
  • 1
    Hey Matt, would you be able to link to the old question to see if this is a duplicate. Maybe the old answer can be updated for the latest version of QGIS. – SaultDon Feb 10 '15 at 17:46
2

With the identify tool, click on a white part of the raster and look for the value.

Then rightclick -> Properties -> Transparency tab, add this value to the NODATA section as an additional NODATA value.

  • AndreJ, when i choose the unwanted value, i also change a lot of important detail in the raster. How can i choose to remove only the white area? – newGIS Jul 15 '17 at 20:28
  • @newGIS I think this is worth opening a new question. You may link to this question. – AndreJ Jul 16 '17 at 5:58
2

Instead of changing the transparency, you can clip the raster by the mask layer. very important to mark those two options so the clip will be accurate:

enter image description here

see my answer in

Remove unwanted black area around clipped raster in QGIS 2.18

2

This may only apply in recent versions of QGIS, but an easier option I have found is to:

• Go to Layer properties>Transparency>Custom Transparency Options and click ‘Add Values From Display’ (the arrow with a question mark) to auto-populate a new line • Then click apply

Make sure the ‘Transparency band’ dropdown is set to ‘None’, unless you want to lose pixels from the remainder of the raster as well. Works best for solid blocks of colour.

0

Right-Click Layer >> Properties >> Style >> and select "Inverted Polygons"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.