1

I have been running into this error in several geoprocessing scripts I've written lately. When I call a spatial analyst function I return this error:

FATAL ERROR (INFDEF) DIRECTORY FULL

The exact function call doesn't seem to matter (but limited to Spatial Analyst functions). In this case the function is arcpy.sa.ExtractByMask, but arcpy.sa.TabulateArea has also caused this error.

What really confuses me is that about 10% of the time the script will succeed without error. I ran across this documentation on the Esri website, that discusses a limit to the number of GRID files that can be stored in a single workspace. This might help explain the problem I'm running into, but it still doesn't explain the intermittent nature of the error, or that there is no issue running these same functions as tools within the desktop software.

Potentially the error is related to an internal conversion of a vector feature to raster format. Is there a temporary work space that can be cleared, do these temporary conversions get written to disk space?

Has anybody else run into this issue?

  • 1
    Please edit the question to specify exactly what your script is doing (with an actual script sample that exhibits the problem), an indication of how many times it is doing it, and a description of your intermediate product cleanup methodology. – Vince Feb 11 '15 at 19:54
3

From the "plenty of space in the directory" statement and questions in the second to last paragraph, it appears you didn't fully understand the reference you cited.

This error has nothing to do with filesystem directories, storage, memory space, or disk space limitations and only occurs when an attempt is made to create more than 9999 tables in an INFO directory (for any reason). As the blog post indicates, there are a number of different ways to add up to 10k INFO files, but once you saturate the arcNNNNdat.adf naming model, all new data creation attempts will fail.

Back before INFO v7 came along, the limit was 999 tables, which could be as few as eighty complex coverages with region topology. You have to work harder to hit the 10k table limit, but it is still possible.

There are several ways to avoid this error:

  1. Don't use Grid as your raster format
  2. Be sure to remove intermediate products in your scratch workspace as part of your looping structure (yes, it's supposed to be temporary, but cleanup is best practice).
  3. Be aware of which commands will be creating a large number of intermediate products in one workspace, and try to avoid providing parameters which will produce excessive intermediate tables or at least specify a subdirectory in system-generated temporary workspace as the temporary working area for those commands.
2

I encountered the same error and eventually traced it to temp files not cleaned up by ArcGIS: An info directory (with 9999 .dat files) was found in:

C:\Users\Dan\AppData\Local\Temp

I deleted the info directory (and associated data) and all is well. Before deletion any Spatial Analyst raster tool would fail from arcpy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.