1

Im using QGIS 2.6 on Ubuntu 14.04. Suddenly a strange caching behaviour appeard in QGIS. When I change the plugin code and try to reload it with for example the Plugin Reloader plugin or when I reload it manually nothing happens. Even after a QGIS restart there is still the old code in the cache. At the moment the only possibility to get the new code into QGIS is to delete my plugin out of the QGIS folder, restart QGIS, put my plugin folder into python/plugins and reload the plugin via Plugin Reloader.

I tried to reload it with qgis.utils.reloadPlugin('MyPlugin') and also with

qgis.utils.unloadPlugin('MyPlugin')
True
qgis.utils.loadPlugin('MyPlugin')
True
qgis.utils.startPlugin('MyPlugin')

The functions returning a True value but nothing happens.

Any ideas what is causing this cache behaviour?

closed as off-topic by underdark Oct 8 '17 at 11:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can't say the same for Ubuntu as I use Windows but what I did when I edited my plugin was to recompile it and then copy/paste the folder into the QGIS folder (this replaces the old version of the plugin). This avoids having to use the Plugin Reloader as QGIS loads the plugin on restart. But as I say, it's probably different for Ubuntu. – Joseph Feb 16 '15 at 11:27
  • If I recompile it and copy and paste it into the folder it works if I restart Qgis as well, which I try to avoid. Before I reloaded the plugin with the function `qgis.utils.reloadPlugin('PluginName'). But suddenly it stopped working. – Martin Feb 16 '15 at 11:58
  • Ah ok, I didn't know you want to avoid that method. It is strange that it stops working all of a sudden. Have you tried the good old-fashioned restarting your computer? Otherwise hopefully others will advise on this weird behavour. – Joseph Feb 16 '15 at 12:09
  • Yes I tried it as well ;). But I have this error since a couple days and I can't find a solution... But thank you for your help! – Martin Feb 16 '15 at 12:14
  • I've deleted everything inside the .qgis2 folder and reinstalled qgis. Now it is working again... – Martin Feb 16 '15 at 13:05