2

This question already has an answer here:

I'm trying to make a raster from an LAS dataset. I want to only use points classified as ground, but I can't figure out how to do this. What I've tried is:

  • Create LAS dataset from 2 .las files.
  • Filter dataset on ground using LAS Dataset to raster tool.
  • Pick the dataset and use linear interpolation on average cell assignment type.

The result is a raster with all points including non-ground points.

When I'm in the LAS Dataset to raster tool I'm choosing an external file that doesn't get affected from what I've done in the LAS Dataset toolbar. How do I make the filter affect the dataset before turning it into a raster?

marked as duplicate by Andre Silva, xunilk, BERA, Evil Genius, aldo_tapia Jun 6 '18 at 13:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Personally I use LAS to Multipoint then, Point to Raster to do that, or I define a Terrain dataset from the Multipoint data and create rasters from there. In the LAS to Multipoint you can filter on LAS classes to include.

If using the LAS Dataset to raster you can approximate a DTM by choosing:

"Cell Assignment Type" = MINIMUM 

but this will only look at point elevation, not classification.

Alternatively, you can set up your LAS data as a mosaic dataset and create raster DTMs from there.

  • I tried all alternatives but none really satisfied my needs: When using LAS to Multipoint then Point to raster I don't get the option to interpolate the data as in LAS Dataset to raster. When using LAS Dataset to raster with minimum cell assignment type it does a poor job at eliminating buildings. When creating mosaic dataset (this is probably a noob misstake) I get two errors: "Insufficient information from raster/raster dataset. Could not update mosaic" "The footprint extent is completely outside the domain extent of the mosaic dataset's coordinate system" – Johan Feb 17 '15 at 10:25
  • It may be that going the way by a Terrain dataset would solve your case. As to the error messages on the mosaic: It may look as if there are some coordinate system definitions not matching up... – HavardMoe Feb 18 '15 at 9:27
  • Yea, I thought it was some geographic system missmatch as well, I never figured out what it was though, I came to another, maybe simpler sulotion, written above. – Johan Feb 18 '15 at 10:15
1

After some research I figured out a way to solve this, much thanks to HavardMoe's input.

Here is how I did it:

  • Used the LAS to Multipoint tool, this is the step where the filtering occurs by choosing specific input class codes and/or specific returns.
  • Then I used one of the interpolation tools listed here.

That gave me the interpolated raster I was looking for.

Not the answer you're looking for? Browse other questions tagged or ask your own question.