3

I have a map on geojson.io, with some errors that I need to correct.

geojson.io edit

It has a feature to edit a polygon's node but it's too tedious and doesn't have "snapping" mode. So I've imported my .geoJSON, .shp, and .topoJSON format files into QGIS.

QGIS edit

And QGIS doesn't enable edit mode. Is it possible to do that or am I on the wrong path? If it's possible, how can I do it?

2

As far as I know, QGIS doesn't support editing GeoJSON or TopoJSON files (I'm not sure you can even load the latter), but your ShapeFiles should be certainly editable. Try again with the Shapefiles, if that works consider converting your GeoJSON and TopoJSON files to Shapefile or, even better, to a database format like SpatiaLite or PostgreSQL/PostGIS.

  • I've tried with .geoJSON, .topoJSON and ShapeFiles formats, QGIS can read it, even show it. But can't edit. Is there some "convert-edit-convert" way I can do it? – Klaujesi Feb 16 '15 at 16:18
  • 2
    You could save your layers to a Shapefile format using right click->"Save as"->ESRI Shapefile, then edit your layers, and then use the same option to save them back to the original formats. Regarding the non-editable Shapefile, do you have it open in another program? If so, close those other programs, they lock your .dbf file and may prevent the Shapefile from being edited. – Germán Carrillo Feb 16 '15 at 16:22
  • 2
    Have you clicked on the dataset in the table of contents? That will activate the Edit button (if the dataset is editable, of course). – BritishSteel Feb 16 '15 at 17:05
  • @gcarrillo. You right, "Save as"->ESRI ShapeFile enable edition. I don't know why, if I've loaded the shape from an ESRI Shape I must to save it to edit. Against my common sense. – Klaujesi Feb 16 '15 at 19:01
  • @Klaujesi That's weird, sure. Well, you could open a new question about that, or let the QGIS community know about that issue by posting to the QGIS users mailing list. By the way, please upvote my answer if it was helpful and please mark it as accepted if it helped you solve your problem. – Germán Carrillo Feb 16 '15 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.