When trying to join Excel datafile to shapefile in ARC GIS 10.2.2 I keep getting the following message: "Failed to connect to database. An underlying database error occurred. Class not registerd." Any ideas how to resolve?

  • 1
    try exporting your excel table as a .dbf or into a geodatabase
    – Maksim
    Feb 17, 2015 at 14:02
  • Have you looked at this? gis.stackexchange.com/questions/13128/…
    – MyFamily
    Feb 17, 2015 at 14:09
  • is this office 64bit?
    – Brad Nesom
    Feb 17, 2015 at 14:49
  • From my expercience joining excel tables often fail. I then export the excel table into a geodatabase (as suggested by @Maksim) and then join this table instead.
    – BERA
    Jan 2, 2017 at 11:23

4 Answers 4


First, open the Excel file in Excel, and then click Save As and select CSV (Either Macintosh or MS DOS works for this purpose) Next, in ArcMap, choose the tool Table to Table and for the input, choose the CSV you just created. Have it output somewhere you can find the table, and the joining should work with the table that was just created.

TL;dr: Save Excel file as a .CSV, use Table to Table tool to convert the .CSV into a .DBF.

  • A longer answer would be preferred.
    – Brad Nesom
    Feb 17, 2015 at 14:46
  • 1
    please edit your original answer and delete the comment.
    – Brad Nesom
    Feb 17, 2015 at 15:05

you need to install the 2007 Office System Driver. It can be downloaded from the Microsoft Download Center. If you do not have any version of Microsoft Excel installed, you must install that driver before you can use either .xls or .xlsx files. If you have Excel 2010 installed, you must still install the driver.


from https://geonet.esri.com/thread/7655


First of all, make sure your excel table is "clean". This may seem obvious, but you'd be surprised...Here's an example of what kind of things you should avoid:


Just with this precaution it should work. However, if it's still not working, use the conversion tools. Conversion tools>Excel>Table to excel and import your excel into a gdb. That should work. If it's still not working, make sure your join fields have the same properties.


First, open the Excel file in Excel, and then click Save As to Excel 2003 format: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.