0

This should be kind of easy but I'm looking for a best practice scenario. I just tried adding 14 points from a point shapefile into another layer in our ArcSDE database. I assumed the layer in SDE was also a point file since it displays as such. I got an error saying there were no files with the appropriate geometry to paste into. I looked and the geometry type of the SDE layer is listed as "Point" but the feature type is "Simple". I inherited this database so I don't know how the layer was created. Is this "simple" geometry something like an event theme (e.g. was it likely just created from a spreadsheet?)?

More importantly, how should I proceed to get the new points from my shapefile into this "Simple geometry" layer?

I also learned just now that the input shapefile has z and m values so I'm exploring stripping those off using "Environment Settings" and the "Copy Features" too.

  • Is it an issue of "simple" points, vs. multipoint feature? – Erica Feb 17 '15 at 20:13
  • Neither layer is multipoint. I'm learning (as I look into this) that the shapefile has z and m values and the output does not so I'm investigating that. – jbchurchill Feb 17 '15 at 20:14
  • It turns out that this is related to the z and m values. The question title is misleading. I considered deleting the question or answering my own question. What would be the preferred course of action here ? – jbchurchill Feb 17 '15 at 20:48
  • 1
    I'd say edit your question to refine it and better describe the actual issue (ie, not misleading), and then answer your own question if you think it will be beneficial to others in the future. Sounds like it might be to me. – Chris W Feb 17 '15 at 21:08
0

I found that the easiest way for me to modify the layer in ArcSDE was to first use the "Copy Features" tool and set the "Environments" so that Z values and M values were both set to "disabled". Then that resulting shapefile could be used to copy and paste features into the ArcSDE layer inside of an edit session.

| improve this answer | |
  • I'm still not sure what exactly caused the problem. Was it the mere presence of z/m values/fields in the shape file and lack of them in the SDE? Obviously, stripping them out resolved the issue, but I saw this blog post which seems to indicate the geometry can have those values and be simple, but if it is aware (ie, has z and m fields) but the fields are empty it becomes non-simple. – Chris W Feb 18 '15 at 22:33
  • Assigning a geometry w/ a Z (or M) to a feature whose feature class is not Z (or M) aware will throw an exception. The easiest way to strip it off in code is to take the source geometry, cast to IZAware and set IZAware.ZAware = false before assigning the geometry to the new feature.Shape. – Chris Kushnir Feb 19 '15 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.