2

I have wind raster datasets for the U.S. that are organized by state and I would like to merge these datasets to get one map of the whole U.S.

I am new to using ArcGIS and through some research I found out that I can do this with the Mosaic To New Raster tool.

The problem that I'm running into is that even though I use the same projection, the raster cells seem to "shift" after having merged them. This can be seen in the pictures I uploaded!

Border of New Hampshire and Maine OriginalBorder of New Hampshire and Maine after merging the datasets

What seems to be the problem here? Is the Mosaic To New Raster tool the right choice? I used "BLEND" as the mosaic operator.

1

As you can see on your first picture, the two raster aren't completely aligned. There are little white gaps where the two rasters meet. They will have to be resampled to fit together into one big raster and it is the result of this that causes the shift that you see in the second illustration.
The resampling is done when the 'Mosaic To New Raster'-tool runs.

You should be careful with this, as your datasets cover a large area, and they may have varying projections, which can cause problems when mosaicing.

  • Thank you very much for your answer! I projected the dataset of each state to the same projection. Can this prevent the problem you mentioned? If just the gaps were resampled that would be ok, but on my computer it looks like the whole dataset shifts. What would be the right approach to merge all these datasets? – Stefanie Feb 18 '15 at 15:00
  • The datasets are not exactly on the same grid. You can see this by drawing a line across the first illustration you made matching the transition between one pixel and the next in the left side of the illustration. This line would not match the transitions in the right side of the illustration. Mosaicing the datasets together will require dealing with this, and resampling one raster into the grid of the second raster is the easiest way to do this, and what ArcGIS is doing. – Mikkel Lydholm Rasmussen Feb 18 '15 at 15:30
  • Thank you for your comment. I found out what part of the problem here is. For each state the dataset has a different UTM. So I want to convert all states to the same UTM. I am just not sure how to do that. – Stefanie Feb 19 '15 at 19:23
  • All the states in the US can't fit into a UTM zone due to the way that referencing system is set up. You'll have to use a different system than UTM, perhaps Albers Equal Area. – Mikkel Lydholm Rasmussen Feb 19 '15 at 20:56
1

You may wish to try a different method of mosaicing rasters.

  1. Create a new mosaic dataset within your Default.GDB (Located in C:\users\myusername\Documents\ArcGIS) by right clicking on the database in the Catalog tree and selecting New > Mosaic Dataset enter image description here

  2. Right click on the new dataset you just created in the Catalog tree and select "Add Rasters". Set the Input Data to be Dataset and then select all your layers from the table of contents and drag it in. Click OK and let it create the mosaic dataset.

  3. I've found that strange things happen with mosaic dataset types (Not appearing at some zoom levels is the most irritating thing), so you may want to convert this to a homogenous raster data type. To do this, use the Mosaic to New Raster. I've never touched any of the settings on this other than inputting the correct # of bands and my input raster data sets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.