1

Using: Mac OSX 10.9.4 QGIS 2.6.1

I had previously installed QGIS and had everything running fine. My home directory was /Users/rowanbado, but for another application I had to add an intermediate directory such that my home directory is now stored in /Users/bado/rowan. Now when I open QGIS I get the following error:

Couldn't load plugin processing due an error when calling its initGui() method

Traceback (most recent call last):
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/qgis/utils.py", line 217, in startPlugin
plugins[packageName].initGui()
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/ProcessingPlugin.py", line 54, in initGui
Processing.initialize()
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/core/Processing.py", line 145, in initialize
Processing.modeler.initializeSettings()
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/modeler/ModelerAlgorithmProvider.py", line 55, in initializeSettings
ModelerUtils.modelsFolder()))
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/modeler/ModelerUtils.py", line 46, in modelsFolder
mkdir(folder)
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/system.py", line 127, in mkdir
mkdir(head)
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/system.py", line 127, in mkdir
mkdir(head)
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/system.py", line 127, in mkdir
mkdir(head)
  File "/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins/processing/tools/system.py", line 129, in mkdir
    os.mkdir(newdir)
OSError: [Errno 13] Permission denied: '/Users/rowanbado'

Which is particularly confusing because that directory no longer exists. I have tried the following workarounds:

-Uninstall and reinstall QGIS (as well as all frameworks, cairo,gdal,etc, and delete ~/.qgis2 folder). Didn't do anything.

-Comment out the line in 'ModelerUtils' (Line 46) which appears to be the source of error. I no longer receive an error message from 'ModelerUtils.py' (so I assume the module is running fine) but instead receive the same message as above except with SystemUtils.py, which I assume is the next module to be initialized. Clearly the issue is with the system.py module.

-Create a symbolic link in /Users/bado/rowan to /Users/rowanbado. Now everything works fine and I have no problems, but this is sort of a 'dumb' work around in that it treats the symptom and no the problem.

It seems that the Processing toolbox has stored a line with my old home directory path in some internal file, and now fails upon initialize and therefore cannot change this line as I assume it should. When I start up the (now working with a symbolic link) toolbox, then remove the symbolic link, I am right back to the same error.

Any developers out there have some idea what's going on and how I can address this? Seems to be a trivial issue to someone who understands the system very well.

1

The problem is that QGIS expects to find the .qgis2 folder in your new Home directory.

Try putting the .qgis2 folder in your new Home directory and deleting the old preference file org.qgis.QGIS2.plist

In this plist file there are many keys with paths values

enter image description here

0

(working with stick standalone version)
after renaming the root directory ("osgeo4w" to "qgis285")i encountered same problem.

solution:

  • look in .qgis2 for dir "QGIS" with file QGIS2.ini
  • delete (rem) all lines with reference to old dir name containing "osgeo4w"
  • restart qgis , QGIS2.ini is rewritten with correct references

conclusion: seemed to be a problem of incomplete refresh of ini file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.