1

I am working on a Debian 7 Wheezy system using Anaconda and working from Spyder. I've had a hard time installing a version of GDAL that reads HDF4 drivers. Could someone walk me through the installation process?

  • Have you tried this approach? – Mike T Feb 18 '15 at 23:43
  • I have. I uninstalled GDAL, reinstalled using jakebrinkmann's comments. When I try to read a HDF file data = gdal.Open(hdffilename) I get the error: 'hdffilename not recognised as supported file format" – Emily Feb 18 '15 at 23:56
  • Did you adress the subdataset in hdffilename? HDFs usually consist of multiple subdatasets. GDAL is able to open the subdatasets but not the HDF "container" as a whole. If you can provide an example file we might be able to determine if that's causing your issue. – Kersten May 26 '15 at 9:16
  • I found that this solution suggested by @Soumya worked in my particular case. Maybe you could try it out? – fdetsch Jan 10 '17 at 10:35
-1

I had the same problem in ubuntu, I did not use anaconda though, just used the ubuntu version of python and my solution is here : https://gis.stackexchange.com/a/148441

Not the answer you're looking for? Browse other questions tagged or ask your own question.