2

I have to run the Whitebox on Linux system, but I am new to use Linux. Therefore, I do not know how to run the whitebox software on Linux. The followings are what I tried to run the software:

~/Desktop/rhessys/Whitebox_3_2_1$ java -version
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)
~/Desktop/rhessys/Whitebox_3_2_1$ ls
lib  logs  README.TXT  ReleaseNotes.txt  resources  WhiteboxGIS.jar
~/Desktop/rhessys/Whitebox_3_2_1$ java -jar  WhiteboxGIS.jar
~/Desktop/rhessys/Whitebox_3_2_1$ 

After typing "java -jar WhiteboxGIS.jar", the software was no response. Or it was running? If it is running how can put data into the whitebox to calculate?

3
  • What Linux OS are you trying to run Whitebox GAT on?
    – SaultDon
    Feb 20, 2015 at 21:26
  • And give the suggestions from this answer a shot too: gis.stackexchange.com/a/116904/1297
    – SaultDon
    Feb 20, 2015 at 21:28
  • Thanks for your reply. I already tried what you suggested. I typed the commands in terminal, but it looked like same with what I have posted. By the way, how to figure out which type of Linux? I am using a network of high performance computers. Feb 20, 2015 at 21:59

1 Answer 1

2

For the text message in your command line, I can observe the last java version ("1.8.0_31"; recommended for the last version of Whitebox GAT 'Iguazu' v. 3.2.1) and the correct unziped directory (Whitebox_3_2_1). However, the suitable command to launch the program is:

java -jar "WhiteboxGIS.jar"

as it is in the README.txt file y not:

"java -jar WhiteboxGIS.jar"

as it is written in your message.

On the other hand, is convenient that you previously run this command:

chmod +x WhiteboxGIS.jar

to ensure that 'WhiteboxGIS.jar' will be an executable file. Linux 'Flavor' is irrelevant in this context because Whitebox GAT was conceived as portable software; independently of the operative system.

In my GNU/Debian system, with 1.8.0_31 java version and in the Whitebox_3_2_1 directory ('Iguazu' version), I launched Whitebox with this command:

java -jar "WhiteboxGIS.jar"

and this was the result:

enter image description here

You may wish to place a shortcut to the .jar file on your desktop for easier access.

9
  • chmod +x WhiteboxGIS.jar is most likely they answer. But in some cases it would of helped to know the Linux OS because some distros have a package available for WhiteboxGAT.
    – SaultDon
    Feb 22, 2015 at 23:14
  • Thanks. I tried your suggestion, but it did not work. No matter which types of command line I typed, I got the same results. There was no above interface coming out. The followings are about the Linux OS: LSB Version:base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch Linux orc129 2.6.32-358.18.1.el6.x86_64 #1 SMP Wed Aug 28 17:19:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux I think may be I need to compile the codes of the software and then run it. Am I right? Feb 23, 2015 at 20:45
  • @Junting Guo Please, run the comand:ls -l WhiteboxGIS.jar and post the result.
    – xunilk
    Feb 23, 2015 at 21:27
  • @xunilk:[junting@orc129 Whitebox_3_2_1]$ ls -l WhiteboxGIS.jar -rwxr-xr-x 1 junting icreed 1015939 Sep 18 19:06 WhiteboxGIS.jar Feb 23, 2015 at 21:31
  • @Junting Guo: You have the privileges for running this software. It is very strange that you can not.
    – xunilk
    Feb 23, 2015 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.