I have a statewide DEM I am trying to create a profile of, however the DEM has some areas of widely varying size (bodies of water) where data was not collected and these areas were all filled by my source as having values of -1. So when I cut a profile graph it is filled with abrupt drops to zero like so:

enter image description here

How can I get the profile graph to skip the -1 values & simply leave those spaces empty?

  • set NoData to -1. If there's already a NoData then you can use ExtractByAttributes (value <> -1) to extract just the good values. I think the profile graph will leave little gaps where the raster is NoData. Let me know if that doesn't work and we'll see if we can fill the -1 values with the surrounding values. – Michael Stimson Feb 25 '15 at 2:57
  • Setting NoData to -1 via ArcCatalog doesn't seem to take, but Extract by attributes works but the profile graph still draws in the no data spots. I just figured out how to export the graph data so I'll put it in excel & work it from there. Going to have to figure out how to how to fill in with surrounding values, DEM is kind of ugly to look at with all those holes. – Alpheus Mar 8 '15 at 6:27
  • Now that you've got NoData you can use IsNull and Eucledian Allocation to fill in the blanks. I'ts not going to be 100% but it's a quick fix. Another viable option is to find the cells that are adjacent to NoData convert to point, triangulate via a Terrain and rasterize then Con(IsNull(DEM),TerrainValue,DEM) in raster calculator. There's two methods that I have used to fill lakes in LiDAR data, both have drawbacks (and both require Spatial Analyst). Is that the sort of thing you'd like to attempt next? – Michael Stimson Mar 8 '15 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.