5

I have a problem with a gap that appears when the setting "only show classes that are visible in the current map extent" is in use and when there is a number of items in a row that does not display;

legend error

Converting the legend to a graphic and doing it manually is not an option. If I switch off the Layer files which fall outside of the view extent, the problem goes away, but then it defies the purpose of this handy (yet frustrating) function.

Any suggestions on how to fix this?

  • How important is the order of your layers? Have you fiddled around with them to pinpoint of it's any particular layer causing this issue? – MyFamily Feb 25 '15 at 15:17
  • If the gap always appears after groundwater contours then put that last... it's a bit hacky but a quick fix nonetheless. Is there a layer that is broken (red exclamation mark)? I have used this feature in previous versions and hadn't noticed a problem. If it persists you may need to upgrade to the most recent version (and ensure all the patches and service packs are installed). I once had a legend that was a real problem (can't remember what) but I ended up having to split it and place as 3 separate legends on a white box - now that's hacky! – Michael Stimson Feb 26 '15 at 5:36
2

This is a documented bug: NIM097138 - An extra white space appears between the legend items when the only show classes that are visible in the current map extent option is checked.

It is not reproducible in 10.2.2, so the simplest solution is to upgrade ArcGIS, if you can.

Alternate Solution according to the bug's description:

  1. Open the legend properties.
  2. In the General Tab, rearrange the legend items to be closer together rather than apart. The legend adjusts accordingly.

(Couldn't figure out what this exactly means and can't test as I work with 10.2.2).

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.