1

Here's the output that Im getting:

Im not sure why it is doing this..

enter image description here

I want it to be more like this

enter image description here

When i try plotting only two counters (two radii): It is giving me this:

enter image description here

I hope it is clearer for you... The code that im using is the same that i posted here: PRACH data mapped right but arcs not on top properly

Also, if i want to sort the percentages by descending order... How can i do that?

  • I'm still not entirely sure what the exact problem is, Yes, I can see the result looks awful but is it also wrong? Is it placing the radii in a wrong position or is it just because you have too many? Is the same with the radii what you are expecting? Can you insert some of your data as comma separated text in the this thread so that I can give it a spin? – Peter Horsbøll Møller Feb 27 '15 at 8:05
2

Okay, I'll give one of your questions an answers: Sorting the radii descending:

If you only have your sectors in the cosmetic layer, save the cosmetic objects into a new table via Map > Save Cosmetic Layer...

Go to Query > SQL Select and fill in the dialog like this:

Select Columns: Area(OBJ, "sq m") "Area_sqm", COL1
From Tables: <your radii table>
Order By Columns: Area_sqm Desc

You need to calculate the area and "add" that as a column. I have done this using this expression: Area(OBJ, "sq m") "Area_sqm". You can add as many of your other columns from the table as you like as well but you need to add them explicitly. In the example above I have only added one additional column - the first in your table.

Now add the query result to you map window and turn off the display of your radii table.

When you add a query to the map MapInfo Pro doesn't use the spatial index when drawing the objects. MapInfo Pro draws them in the order the objects have in the query. Therefor ordering the table with the larger objects first will make MapInfo Pro draw these first and then the smaller object on top.

  • Hello, I just tried it and it is giving me an error: 1: argument Area has an invalid type. Do you have an idea how can it be fixed? Appreciate it – Karl Mar 2 '15 at 15:28
  • I forgot to tag you - @Peter Horsbøll Møller – Karl Mar 2 '15 at 15:30
  • Changed the SQL Select to also include the calculated area that can be used for sorting. – Peter Horsbøll Møller Mar 3 '15 at 6:49
0

Following MI tool may help you in what you are trying to achieve ,

http://telecomfunda.com/forum/showthread.php?36073-RSRAN104-PRACH-DELAY-Report-Mapping-on-Mapinfo

  • Hello Shoib, Unfortunately, i dont have enough points to download it... Can you assist in a different way? That would really be helpful. Thanks! @Shoib Ansari – Karl Jun 2 '15 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.