3

I install QGIS 2.8 in debian (linux) through nightly jessie (qgis testing) and I see that SAGA is not in processing toolbox, so I install saga gis software but still it doesn't appear in processing.

How do I run SAGA in processing toolbox?

UPDATE:

This problem is resolved through the line commands:

sudo add-apt-repository ppa:johanvdw/saga-gis

sudo apt-get update

sudo apt-get install saga

But in my case (Debian Jessie) instead of sudo add-apt-repository ppa:johanvdw/saga-gis I went to https://launchpad.net/~johanvdw/+archive/ubuntu/saga-gis and in Technical details about this PPA I choose Trusty version, copy the lines and paste in sources.list. It works!!!

  • In Processing -> Options -> Data Provider, have you activated SAGA? – AndreJ Feb 26 '15 at 17:07
  • Yes, I activate SAGA in processing options. However, it still down't appear in processing toolbox. I have SAGA installed and I test with saga_cmd command. It works. But with processing it doesn't. – Bárbara Duarte Feb 26 '15 at 17:10
  • Did you switch to the advanced view? It just looks like there is no SAGA in the simplified view. (Dropbox at the bottom of the toolbox.) – underdark Feb 26 '15 at 20:09
  • Check that the box SAGA 2.0.8 compatibility is not checked. – johanvdw Mar 2 '15 at 8:43
  • I switch to the advanced view but there isn't SAGA there. The SAGA 2.0.8 compatibility box isn't in the processing options. There are only these options for SAGA: Activate (check on), Enable SAGA Import/Export optimizations, Log console output, Log execution commands. It is strange for me. – Bárbara Duarte Mar 2 '15 at 10:23
2

I had the same problem, but, looking on the web, I found a solution. Simply, I installed SAGA from other repository (Installing SAGA GIS 2.1).

Try the following commands from a command line:

sudo add-apt-repository ppa:johanvdw/saga-gis

sudo apt-get update

sudo apt-get install saga

I hope it works.

  • Can confirm the problem (my Debian Linux still uses v2.1.2, which is not recognized anymore by QGIS). Installing the debs from this link creates a new Processing-Provider entry for SAGA 2.1.4 – Curlew Mar 2 '15 at 15:33
1

For anyone else who would like to have SAGA 2.1.4 in Jessie: After jessie is released I will try to add it to backports. In the mean time, I recommend using the packages from unstable. These will work with jessie without needing to recompile. You will need to install both libsaga and saga.

https://packages.debian.org/nl/sid/saga https://packages.debian.org/nl/sid/libsaga

0

I try the commands in terminal but it didn't work and I get this error (I suppose it is not correct):

sudo apt-get update
Hit http://ftp.pt.debian.org jessie InRelease
Hit http://ftp.pt.debian.org jessie-updates InRelease                          
Hit http://ftp.pt.debian.org jessie-backports InRelease                        
Ign http://ppa.launchpad.net jessie InRelease                                  
Hit http://security.debian.org jessie/updates InRelease                        
Ign http://ppa.launchpad.net jessie InRelease                                  
Ign http://ppa.launchpad.net jessie InRelease                                  
Get:1 http://ftp.pt.debian.org jessie/main Sources/DiffIndex [7,876 B]         
Ign http://ppa.launchpad.net jessie InRelease                                  
Get:2 http://qgis.org sid InRelease [3,341 B]                                  
Ign http://ppa.launchpad.net jessie InRelease                           
Ign http://ppa.launchpad.net jessie InRelease                           
Ign http://ppa.launchpad.net jessie InRelease                           
Ign http://ppa.launchpad.net jessie Release.gpg                         
Ign http://ppa.launchpad.net jessie Release.gpg                         
Ign http://ppa.launchpad.net jessie Release.gpg                         
Get:3 http://ftp.pt.debian.org jessie/main amd64 Packages/DiffIndex [7,876 B]
Get:4 http://ftp.pt.debian.org jessie/main Translation-en/DiffIndex [7,876 B]
Ign http://ppa.launchpad.net jessie Release.gpg   
Ign http://ppa.launchpad.net jessie Release.gpg   
Ign http://ppa.launchpad.net jessie Release.gpg   
Ign http://ppa.launchpad.net jessie Release.gpg   
Ign http://ppa.launchpad.net jessie Release       
Ign http://ppa.launchpad.net jessie Release       
Ign http://ppa.launchpad.net jessie Release                              
Ign http://ppa.launchpad.net jessie Release                              
Hit http://ftp.pt.debian.org jessie-updates/main Sources                       
Ign http://qgis.org sid InRelease                                              
Hit http://ftp.pt.debian.org jessie-updates/main amd64 Packages                
Hit http://ftp.pt.debian.org jessie-updates/main Translation-en                
Hit http://ftp.pt.debian.org jessie-backports/main Sources                     
Hit http://ftp.pt.debian.org jessie-backports/main amd64 Packages              
Ign http://ppa.launchpad.net jessie Release                                    
Ign http://ppa.launchpad.net jessie Release                                    
Hit http://ftp.pt.debian.org jessie-backports/main Translation-en              
Ign http://ppa.launchpad.net jessie Release                                    
Ign http://qgis.org sid/main Sources/DiffIndex                        
Hit http://security.debian.org jessie/updates/main Sources
Hit http://security.debian.org jessie/updates/main amd64 Packages
Hit http://security.debian.org jessie/updates/main Translation-en     
Ign http://qgis.org sid/main amd64 Packages/DiffIndex                 
Hit http://qgis.org sid/main amd64 Packages                                    
Ign http://qgis.org sid/main Translation-en_US                                 
Err http://ppa.launchpad.net jessie/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US                     
Ign http://qgis.org sid/main Translation-en                                    
Ign http://ppa.launchpad.net jessie/main Translation-en                        
Err http://ppa.launchpad.net jessie/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US                     
Ign http://ppa.launchpad.net jessie/main Translation-en                        
Hit http://qgis.org sid/main Sources                                           
Err http://ppa.launchpad.net jessie/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US                     
Ign http://ppa.launchpad.net jessie/main Translation-en                        
Err http://ppa.launchpad.net jessie/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US                     
Ign http://ppa.launchpad.net jessie/main Translation-en                        
Err http://ppa.launchpad.net jessie/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US                     
Ign http://ppa.launchpad.net jessie/main Translation-en                        
Err http://ppa.launchpad.net jessie/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US                     
Ign http://ppa.launchpad.net jessie/main Translation-en                        
Err http://ppa.launchpad.net jessie/main amd64 Packages                        
  404  Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US                     
Ign http://ppa.launchpad.net jessie/main Translation-en                        
Fetched 27.0 kB in 10s (2,690 B/s)                                             
W: GPG error: http://qgis.org sid InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 030561BEDD45F6C3
W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/johanvdw/saga-gis/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/otb/orfeotoolbox-nightly/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/otb/orfeotoolbox-stable/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/otb/orfeotoolbox-stable-ubuntugis/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
  • These ppa are for ubuntu, so jessie is not known there. The ubuntu equivalent for debian jessie is trusty, utopic or vivid. But I have no experience if mixing ubuntu and debian packages works. Maybe you better compile from source to get a clean SAGA. – AndreJ Mar 2 '15 at 16:06
  • Can you explain to me how I compile from source? I am new with linux. Thank you. – Bárbara Duarte Mar 2 '15 at 16:11
  • Ok, that's no good way to start. Do you have no chance to switch to ubuntu, which is more new-user-friendly? – AndreJ Mar 2 '15 at 16:12
  • Never mind. I try like you said, with trusty and it works. Now, QGIS processing toolbox have SAGA version 2.1.4. Thanks so much. – Bárbara Duarte Mar 2 '15 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.