7

When I try to create a New Mapset with the GRASS plugin in QGIS I get an error or the program crashes.

  • QGIS 2.6.1 (32-bit install, Win7). QGIS crashes completely when clicking "Finish" in the New Mapset window .
  • QGIS 2.8.1 (64-bit install, Win8.1). I get an error message "Cannot activate grass", when I click "Finish" in the New Mapset window .

I have tried on two different computers running Windows 7 and Windows 8.1. I have checked that the GRASS plug-in is activated in "Manage and install plugins...".

  • 1
    I have heard of this being a problem where people can't write to their own C drive - are you on a secure PC setup that stops programmes writing there? – Neil Benny Feb 27 '15 at 11:05
  • The Win8.1 laptop is my own and my user is registered as admin. I also tried to run QGIS as administrator, but I get the same error. – Chris Feb 27 '15 at 11:11
  • The Win7 laptop is a work computer and has some restrictions, but I have enough privileges to install new programs for instance. However, if I am in the QGIS environment and want to create a new folder while saving my QGIS project I get prompted by the windows "User Account Control" to approve. Maybe you are right that some writing restrictions creates the problem. – Chris Feb 27 '15 at 11:16
  • 1
    I have changed the windows user account control setting to the lowest level and it solves the problem on my Win7 machine. Thanks for leading me in that direction @NeilBenny Unfortunately the same trick did not resolve the problem on my Win8 machine. – Chris Feb 27 '15 at 12:47
  • 2
    I am having this issue with QGis 2.8.1 on Ubuntu 14.04. I am trying to create a new mapset in a folder where my user has full permissions, so this problem likely has a different nature. Any help appreciated. – Luís de Sousa Mar 12 '15 at 11:20
3

On QGis 2.8 this problem is caused by a known, but yet unreported bug (access to the QGis bug tracker seems restricted). Before it is fixed it is not possible to create new mapsets in QGis.

However, the user can create a new mapset directly with GRASS and then open it with the GRASS plug-in in QGis.

2

I've just installed the latest development version of QGIS (6 April) and the bug that prevented the creation of new Grass mapsets has been fixed - all now works just as expected.

Hats off the to QGIS development team!

  • Will this be backported to the standard release? Since not all users can install development versions... – markusN Aug 24 '15 at 22:29
  • I can't test at the moment but as this was fixed in April I'm assuming it's world it's way into the newer stable production releases that became available since then. If it's not working for you, may be update QGIS to the current stable version? – Adrian Aug 26 '15 at 7:00
1

I have changed the windows user account control setting to the lowest level and it solves the problem on my Win7 machine. Thanks for leading me in that direction @NeilBenny Unfortunately the same trick did not resolve the problem on my Win8 machine.

  • This is not a solution to the problem. You can not set a user to "the lowest level" on Linux or Mac. – Luís de Sousa Mar 12 '15 at 11:23
  • 1
    @LuísdeSousa the question is on QGIS on Windows 7 and 8, not on Linux and Mac. That it is a broader issue which also includes those platforms is of course of interest, but changing the user access control did solve the issue for me on Win7. – Chris Mar 13 '15 at 9:32
  • 1
    I have the same issue on Windows 7 using QGIS 2.8/9 but I'm not sure I know what "setting a user to the lowest level" means. I understood Windows has only users and administrators, and I've tried both to no avail. – Adrian Mar 13 '15 at 15:19
  • @Adrian, here is a guide on how to turn "user access control" (UAC) off in Windows 7. Let me know if it works for you as well: windows.microsoft.com/en-us/windows/… – Chris Mar 20 '15 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.