3

I posted this on digitalocean, but it's imperative I resolve this problem.

Freshly updated 14.04 and I went from trying qgis.org debian to the ubuntugis repo. Results:

xx@XX:~$ sudo apt-get install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

However:

xx@XX:~$ sudo apt-get install libcheese-gtk23 libcheese7
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcheese-gtk23 is already the newest version.
libcheese7 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I have made several attempts at this by purging, auto removing, etc. I'm at a loss.

Additionally, with the QGIS and ubuntugis repos added, I try to install from software center and get this error:

The following packages have unmet dependencies:

unity-control-center: Depends: libpulse-mainloop-glib0 (>= 1:0.99.1) but 1:4.0-0ubuntu11.1 is to be installed
                      Depends: libpulse0 (>= 1:0.99.1) but 1:4.0-0ubuntu11.1 is to be installed
                      Depends: libxi6 (>= 2:1.2.99.4) but 2:1.7.1.901-1ubuntu1 is to be installed

When I go to update them, terminal says they are up to date.

  • 1
    The unity-control-center package has nothing to do with QGIS, so this might better be adressed at askubuntu.com – AndreJ Feb 28 '15 at 6:16
  • I've encountered this issue on qgis 2.8 installation. Is still unresolved? Thanks Dario – Dario Jun 19 '15 at 19:13
  • I used a fresh install of unity and then installed qgis through the app manager. After installation, I removed qgis (that is, I got the necessary packages I needed for 2.8) and installed 2.8 using the official repo. It works perfectly, so I'm guessing it was just a bad file somewhere in my original copy of unity or the dependencies. Either way, install the old version, uninstall, and then install the new version. – pkowalewska Jun 20 '15 at 22:04
  • didn't fix the problem... anyhow thanks a lot for your advice. I'll asap in a fresh machine. – Dario Jun 22 '15 at 17:11
2

I always had perfect installations when following the instructions on the official QGIS download site:

http://www2.qgis.org/en/site/forusers/alldownloads.html#ubuntu

Have you tried those? The instructions on the QGIS download site are not as intuitive as I'd like, but they do work when you know the command syntax.

This set of commands always gets me a complete clean install on Ubuntu:

sudo sh -c 'echo "deb http://qgis.org/debian trusty main" >> /etc/apt/sources.list'  

sudo sh -c 'echo "deb-src http://qgis.org/debian trusty main" >> /etc/apt/sources.list'  

gpg --keyserver keyserver.ubuntu.com --recv 47765B75  

gpg --export --armor 47765B75 | sudo apt-key add -  

sudo apt-get update && sudo apt-get install qgis python-qgis  
  • That was the way I was installing, and I get the above mentioned problems. – pkowalewska Feb 27 '15 at 19:00
  • my solution doesn't involve the UbuntuGIS project... I'm reading that you're using both the QGIS.org repo's and the UbuntuGIS repo's... is that correct? – DPSSpatial Feb 27 '15 at 19:14
  • I used them exclusively of each other. That is, I tried one, which resulted in the error, so I switched to the other, which also resulted in the error. The point is I tried both. Instead I tried reinstalling 14.04 anew, which resulted in some other package dependency errors. The solution: install aptitude and install qgis from there. – pkowalewska Feb 27 '15 at 19:56
  • The error the OP is seeing comes from following these exact instructions. The fix posted by user2295819 below appears to work. – John Powell Jun 1 '16 at 13:33
1

I have found a solution that worked for me on launchpad.net, it's described here (see answer #11 by Manfred Hampl): https://answers.launchpad.net/ubuntu/+source/qgis/+question/262666

Basically these are the commands I ran per suggestion on launchpad:

sudo apt-get update
sudo apt-get dist-upgrade
sudp dpkg --audit
sudo apt-get install gstreamer1.0-clutter libcheese7 libcheese-gtk23 libclutter-1.0-0 libclutter-gst-2.0-0 libclutter-gtk-1.0-0 libcogl15 libcogl-pango15 python-qgis qgis

I now have both QGIS Desktop and QGIS Browser up an running.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.