1

I have an ArcGIS server set up. It works, but only when I access the server (or server manager) via a web browser from the server machine itself. I am unable to access the server (using the same url) from another machine (Chrome: "This webpage is not available").

I have a website set up on the same domain (mydomain.edu), which works just fine. I am only having problems with the ArcGIS server (mydomain.edu:port_number/arcgis). Am I attempting to access this website incorrectly? Is there a setting which needs to be changed in order to allow remote access?

The main problem is that I want to be able to publish map services to the server remotely, which I am unable to do at the moment. ArcMap is unable to connect to the server.

Any advice from the gurus?

  • 3
    Have you checked the firewall settings? – BradHards Mar 1 '15 at 0:58
  • Are you running a Port Adapter on port 80 and/or 443? Did you open port 6080/6443/whatever for access from your remote publishing host? – Vince Mar 1 '15 at 4:43
  • open a CMD prompt from the remote machine. Can you ping the machine? – Simon Mar 1 '15 at 6:12
1

What is the port number in your url (mydomain.edu:port_number/arcgis). Your server firewall must allow communication through this port. Furthermore your client-machine must be able to connect to server via this port. In some organizations, IT administrator, block unpopular ports in client machines.

Because you have mentioned:

I have a website set up on the same domain (mydomain.edu), which works just fine.

So you can ping your server and port 80 is open.

Advices:

  • To make sure this problem is related to firewall, turn off your firewall in both server and client machine and to how it works.

  • Try to access the server via its IP rather that its domain name (e.g. 192.168.0.1:6080/arcgis)

  • 2
    Answers should not be a litany of questions (especially questions already asked in comments, where questions to the OP belong). If you want fashion a long answer based in assumptions, you can caveat the answer in those terms, but if half the answer is questions, it's probably better to wait until the OP clarifies the question. – Vince Mar 1 '15 at 14:36
  • 1
    Actually this is super helpful and confirmed several suspicions that I had. Thanks Farid! I'll do this and see if any of it helps. – gisuser Mar 1 '15 at 20:04
  • 1
    It was solved via the firewall, just like you suggested. Thanks! – gisuser Mar 7 '15 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.