1

I can import my large csv file into ArcGis Desktop and I can view it in Catalog and everything looks fine. When I go to 'create feature class' it does not recognize the column that I need to use for the z value. It is not an option I can pick.

I'm using ArcGIS 10.2 for Desktop and trying to do this in Catalog.


This is what I get when I try to make the XY shapefile. No Z options.

  • 4
    Have you got any non-numerical values in this column? – whatahitson Mar 2 '15 at 17:49
  • 2
    Does your csv file contain headers (X,Y,Z) at the top row? – Farid Cheraghi Mar 2 '15 at 17:51
  • 1
    @Jill the NA values are most likely the culprit I would change them to an integer value that you will recognize as null like 999. Zero works as long as you don't have any other zero values for temperature. – landocalrissian Mar 2 '15 at 20:12
  • 1
    Please edit your post to include both your header row and a few sample rows of the data. It's possible you have an invalid field name. It's also possible that it isn't recognizing the data type correctly and you need a schema.ini file. When you say did one year and left out the other 11, is each year a row or a column? It's unclear how your data is organized. – Chris W Mar 3 '15 at 1:11
  • 1
    Export csv to table and check field type for 'z' column – FelixIP Mar 3 '15 at 4:50
2

Right click your table in the "Table of Contents" click "Display XY Data." Choose whichever fields map to X, Y, and Z, then choose your coordinate system. Right click the event layer, and export to your desired location.

Display XY Data

  • It does not give me the option of selecting anything for the z field. It has a <none>, lat or long which are the xy but the temperature field is not 'seen' even though when I preview the table it is there. – Jill Mar 2 '15 at 19:54
  • What version of ArcMap are you using? refer to my image, hopefully it looks similar. – Maksim Mar 2 '15 at 19:54
  • I'm using 10.2 and was trying to do this in Catalog,not map. Hmm maybe I'll try that! – Jill Mar 2 '15 at 20:13
  • 2
    As I stated in the comments its likely that the non numerical values in the Z field are causing it to not be recognized as a usable Z value. – landocalrissian Mar 2 '15 at 20:14
  • OK I will try changing them to 0s but it is strange that it worked before even if it only used 1 year of data. The year it did use had non-numeric values in the z column as well. THank you for the suggestion! – Jill Mar 2 '15 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.